summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-19 20:20:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-19 20:20:23 +0000
commitf528ef668e52b944837daf8a700c761ef426b18a (patch)
tree95c46ccff1bdc7e33d09be5f9825d405db06902e /games-arcade
parentAdded a patch to avoid linking to G4zlib, closing bug #255017, thanks to Benj... (diff)
downloadgentoo-2-f528ef668e52b944837daf8a700c761ef426b18a.tar.gz
gentoo-2-f528ef668e52b944837daf8a700c761ef426b18a.tar.bz2
gentoo-2-f528ef668e52b944837daf8a700c761ef426b18a.zip
EAPI=2; add use-based dep; build cpp files with the c++ compiler
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/tomatoes/ChangeLog8
-rw-r--r--games-arcade/tomatoes/tomatoes-1.55-r2.ebuild23
2 files changed, 13 insertions, 18 deletions
diff --git a/games-arcade/tomatoes/ChangeLog b/games-arcade/tomatoes/ChangeLog
index ec81ccd0329f..4021fe1afa73 100644
--- a/games-arcade/tomatoes/ChangeLog
+++ b/games-arcade/tomatoes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/tomatoes
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/ChangeLog,v 1.15 2008/05/01 15:53:35 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/ChangeLog,v 1.16 2009/01/19 20:20:23 mr_bones_ Exp $
+
+ 19 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ tomatoes-1.55-r2.ebuild:
+ EAPI=2; add use-based dep; build cpp files with the c++ compiler
01 May 2008; Tristan Heaven <nyhm@gentoo.org>
+files/tomatoes-1.55-gcc43.patch, tomatoes-1.55-r2.ebuild:
diff --git a/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild b/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild
index c18402281a19..0fd14f65ede5 100644
--- a/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild
+++ b/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild,v 1.5 2008/05/01 15:53:35 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild,v 1.6 2009/01/19 20:20:23 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DATA_PV=1.5
@@ -19,27 +20,17 @@ DEPEND="virtual/opengl
virtual/glu
media-libs/libsdl
media-libs/sdl-image
- media-libs/sdl-mixer"
+ media-libs/sdl-mixer[mikmod]"
-pkg_setup() {
- if ! built_with_use media-libs/sdl-mixer mikmod ; then
- eerror "Tomatoes doesn't work properly if sdl-mixer"
- eerror "is built with USE=-mikmod"
- die "Please emerge sdl-mixer with USE=mikmod"
- fi
- games_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
mv ../tomatoes-1.5/* . || die "mv failed"
mv icon.png ${PN}.png
sed -i \
-e '/^CC/d' \
-e '/^MARCH/d' \
- -e "/^CFLAGS/s/=.*$/= ${CFLAGS} \$(SDL_FLAGS)/" \
+ -e "/(CFLAGS)/s/CC/CXX/" \
+ -e "/^CFLAGS/s/=.*$/= ${CXXFLAGS} \$(SDL_FLAGS)/" \
-e "/^LDFLAGS/s/-s$/${LDFLAGS}/" \
-e "/^MPKDIR = /s:./:${GAMES_DATADIR}/${PN}/:" \
-e "/^MUSICDIR = /s:./music/:${GAMES_DATADIR}/${PN}/music/:" \