summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-11-29 21:47:47 +0000
committerHanno Böck <hanno@gentoo.org>2005-11-29 21:47:47 +0000
commite0228692b24aff99aead67de4f09315d0d68a095 (patch)
tree81dcd3c6271de9d2bcd262b1c426b49b585ddcbe /games-arcade
parentstable on ppc64 (diff)
downloadgentoo-2-e0228692b24aff99aead67de4f09315d0d68a095.tar.gz
gentoo-2-e0228692b24aff99aead67de4f09315d0d68a095.tar.bz2
gentoo-2-e0228692b24aff99aead67de4f09315d0d68a095.zip
ppracer gcc41 fix
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/ppracer/ChangeLog6
-rw-r--r--games-arcade/ppracer/files/ppracer-0.3.1-gcc41.patch11
-rw-r--r--games-arcade/ppracer/ppracer-0.3.1.ebuild5
3 files changed, 20 insertions, 2 deletions
diff --git a/games-arcade/ppracer/ChangeLog b/games-arcade/ppracer/ChangeLog
index 2de179edaa31..e563e22dcfcb 100644
--- a/games-arcade/ppracer/ChangeLog
+++ b/games-arcade/ppracer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/ppracer
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/ppracer/ChangeLog,v 1.11 2005/11/14 09:58:32 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/ppracer/ChangeLog,v 1.12 2005/11/29 21:47:47 hanno Exp $
+
+ 29 Nov 2005; Hanno Boeck <hanno@gentoo.org>
+ +files/ppracer-0.3.1-gcc41.patch, ppracer-0.3.1.ebuild:
+ Fix for gcc 4.1.
14 Nov 2005; Herbie Hopkins <herbs@gentoo.org> ppracer-0.3.1.ebuild:
Multilib fix
diff --git a/games-arcade/ppracer/files/ppracer-0.3.1-gcc41.patch b/games-arcade/ppracer/files/ppracer-0.3.1-gcc41.patch
new file mode 100644
index 000000000000..6f5348ead4f8
--- /dev/null
+++ b/games-arcade/ppracer/files/ppracer-0.3.1-gcc41.patch
@@ -0,0 +1,11 @@
+--- ppracer-0.3.1/src/ppgltk/FT/FTTextureGlyph.h 2005-02-18 11:16:04.000000000 +0100
++++ ppracer-0.3.1-gcc41/src/ppgltk/FT/FTTextureGlyph.h 2005-11-29 22:16:49.198509000 +0100
+@@ -52,7 +52,7 @@
+ * Reset the currently active texture to zero to get into a known state before
+ * drawing a string. This is to get round possible threading issues.
+ */
+- static void FTTextureGlyph::ResetActiveTexture(){ activeTextureID = 0;}
++ static void ResetActiveTexture(){ activeTextureID = 0;}
+
+ private:
+ /**
diff --git a/games-arcade/ppracer/ppracer-0.3.1.ebuild b/games-arcade/ppracer/ppracer-0.3.1.ebuild
index d25ecf6175e2..e4a182c04c12 100644
--- a/games-arcade/ppracer/ppracer-0.3.1.ebuild
+++ b/games-arcade/ppracer/ppracer-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/ppracer/ppracer-0.3.1.ebuild,v 1.5 2005/11/14 09:58:32 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/ppracer/ppracer-0.3.1.ebuild,v 1.6 2005/11/29 21:47:47 hanno Exp $
inherit flag-o-matic gnuconfig games multilib
@@ -26,6 +26,9 @@ DEPEND="virtual/opengl
src_unpack() {
unpack ${A}
cd "${S}"
+
+ epatch ${FILESDIR}/ppracer-0.3.1-gcc41.patch
+
gnuconfig_update
autoconf || die "autoconf failed"
}