summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-30 16:12:06 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-30 16:12:06 +0000
commit335615e9ee99ff9da7538f520f26622f2fb51a32 (patch)
tree4cd0ec9ab04cc1103d4cccb042126dc0de6b5ec9 /games-arcade
parentdev-util/patchelf: Drop old (diff)
downloadgentoo-2-335615e9ee99ff9da7538f520f26622f2fb51a32.tar.gz
gentoo-2-335615e9ee99ff9da7538f520f26622f2fb51a32.tar.bz2
gentoo-2-335615e9ee99ff9da7538f520f26622f2fb51a32.zip
version bump wrt #454624
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/berusky/ChangeLog10
-rw-r--r--games-arcade/berusky/berusky-1.6.ebuild58
-rw-r--r--games-arcade/berusky/files/berusky-1.6-gentoo.patch71
3 files changed, 137 insertions, 2 deletions
diff --git a/games-arcade/berusky/ChangeLog b/games-arcade/berusky/ChangeLog
index 10817a625412..420a5c011453 100644
--- a/games-arcade/berusky/ChangeLog
+++ b/games-arcade/berusky/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/berusky
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/berusky/ChangeLog,v 1.8 2012/11/15 22:46:06 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/berusky/ChangeLog,v 1.9 2013/01/30 16:12:06 hasufell Exp $
+
+*berusky-1.6 (30 Jan 2013)
+
+ 30 Jan 2013; Julian Ospald <hasufell@gentoo.org> +berusky-1.6.ebuild,
+ +files/berusky-1.6-gentoo.patch:
+ version bump wrt #454624
*berusky-1.5.2 (15 Nov 2012)
diff --git a/games-arcade/berusky/berusky-1.6.ebuild b/games-arcade/berusky/berusky-1.6.ebuild
new file mode 100644
index 000000000000..75f9d60fbbf2
--- /dev/null
+++ b/games-arcade/berusky/berusky-1.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/berusky/berusky-1.6.ebuild,v 1.1 2013/01/30 16:12:06 hasufell Exp $
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DATAFILE=${PN}-data-${PV}
+DESCRIPTION="free logic game based on an ancient puzzle named Sokoban"
+HOMEPAGE="http://anakreon.cz/?q=node/1"
+SRC_URI="http://www.anakreon.cz/download/${P}.tar.gz
+ http://www.anakreon.cz/download/${DATAFILE}.tar.gz
+ http://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[X,video]
+ media-libs/sdl-image[png]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ mv ../${DATAFILE}/{berusky.ini,GameData,Graphics,Levels} . || die
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
+ src/defines.h berusky.ini \
+ || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r berusky.ini GameData Graphics Levels
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN}
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-arcade/berusky/files/berusky-1.6-gentoo.patch b/games-arcade/berusky/files/berusky-1.6-gentoo.patch
new file mode 100644
index 000000000000..f26c233c39e0
--- /dev/null
+++ b/games-arcade/berusky/files/berusky-1.6-gentoo.patch
@@ -0,0 +1,71 @@
+--- Makefile.am
++++ Makefile.am
+@@ -5,8 +5,7 @@
+
+ SUBDIRS = po src data
+
+-beruskydocdir = ${prefix}/doc/berusky
+-beruskydoc_DATA = \
++EXTRA_DIST = \
+ README\
+ COPYING\
+ AUTHORS\
+@@ -15,10 +14,6 @@
+ NEWS\
+ TODO
+
+-EXTRA_DIST = $(beruskydoc_DATA)
+-
+-
+-
+ # Copy all the spec files. Of cource, only one is actually used.
+ dist-hook:
+ for specfile in *.spec; do \
+--- data/Makefile.am
++++ data/Makefile.am
+@@ -3,10 +3,3 @@
+ ## Created by Anjuta - will be overwritten
+ ## If you don't want it to overwrite it,
+ ## Please disable it in the Anjuta project configuration
+-
+-berusky_datadir = $(prefix)/@NO_PREFIX_PACKAGE_DATA_DIR@/@PACKAGE@
+-
+-berusky_data_DATA = \
+- berusky.ini
+-
+-EXTRA_DIST = $(berusky_data_DATA)
+--- berusky.ini
++++ berusky.ini
+@@ -1,9 +1,9 @@
+ # Configuration for berusky game
+
+ # Game data location
+-level_data = /usr/share/berusky/Levels
+-game_data = /usr/share/berusky/GameData
+-graphics_data = /usr/share/berusky/Graphics
++level_data = @GENTOO_DATADIR@/Levels
++game_data = @GENTOO_DATADIR@/GameData
++graphics_data = @GENTOO_DATADIR@/Graphics
+
+ # Graphics settings for game and editor
+ # game runs in 640x480
+@@ -17,7 +17,7 @@
+
+ # Game binary & tmp dir
+ # they're used by editor for "run level" command
+-game_binary = /usr/bin/berusky
++game_binary = @GENTOO_BINDIR@/berusky
+ tmp_data = /var/tmp
+
+ # Dir for users levels (it's the default level dir for level editor)
+--- src/defines.h
++++ src/defines.h
+@@ -446,7 +446,7 @@
+ #define INI_USER_DIRECTORY "~/.berusky"
+ #define INI_USER_LEVELS "~/.berusky/User"
+ #define INI_USER_PROFILES "~/.berusky/Profiles"
+-#define INI_FILE_GLOBAL "/var/games/berusky/"INI_FILE_NAME
++#define INI_FILE_GLOBAL "@GENTOO_DATADIR@/"INI_FILE_NAME
+ #define INI_FILE_USER "~/.berusky/"INI_FILE_NAME
+ #define INI_FILE_LOCAL "./"INI_FILE_NAME
+ #elif WINDOWS