summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-02-21 20:51:12 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-02-21 20:51:12 +0000
commit25ad2c7806a1303cdcd6dd60d877747f811c9610 (patch)
tree44a2b5308b815e0d3244e655897310d6b92214bb /games-arcade
parentmarked x86 per bug 403405 (diff)
downloadgentoo-2-25ad2c7806a1303cdcd6dd60d877747f811c9610.tar.gz
gentoo-2-25ad2c7806a1303cdcd6dd60d877747f811c9610.tar.bz2
gentoo-2-25ad2c7806a1303cdcd6dd60d877747f811c9610.zip
Version bump to 0.6.1 and rename from ultrastar-ng to performous. Bug #245452
(Portage version: 2.1.10.48/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/performous/ChangeLog12
-rw-r--r--games-arcade/performous/files/performous-0.6.1-ffmpeg.patch13
-rw-r--r--games-arcade/performous/files/performous-0.6.1-gentoo.patch29
-rw-r--r--games-arcade/performous/files/performous-0.6.1-libpng.patch11
-rw-r--r--games-arcade/performous/metadata.xml15
-rw-r--r--games-arcade/performous/performous-0.6.1.ebuild92
6 files changed, 172 insertions, 0 deletions
diff --git a/games-arcade/performous/ChangeLog b/games-arcade/performous/ChangeLog
new file mode 100644
index 000000000000..7ff1f9647ea4
--- /dev/null
+++ b/games-arcade/performous/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for games-arcade/performous
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.1 2012/02/21 20:51:12 tupone Exp $
+
+*performous-0.6.1 (21 Feb 2012)
+
+ 21 Feb 2012; Tupone Alfredo <tupone@gentoo.org> +performous-0.6.1.ebuild,
+ +files/performous-0.6.1-ffmpeg.patch, +files/performous-0.6.1-gentoo.patch,
+ +files/performous-0.6.1-libpng.patch, +metadata.xml:
+ Version bump to 0.6.1 and rename from ultrastar-ng to performous. Bug #245452
+ by Vincent Le Ligeour
+
diff --git a/games-arcade/performous/files/performous-0.6.1-ffmpeg.patch b/games-arcade/performous/files/performous-0.6.1-ffmpeg.patch
new file mode 100644
index 000000000000..38adb751d3b1
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.6.1-ffmpeg.patch
@@ -0,0 +1,13 @@
+--- game/ffmpeg.cc.old 2012-02-19 09:01:01.086108323 +0100
++++ game/ffmpeg.cc 2012-02-19 09:02:27.157984673 +0100
+@@ -60,8 +60,8 @@
+ for (unsigned int i=0; i<pFormatCtx->nb_streams; i++) {
+ AVCodecContext* cc = pFormatCtx->streams[i]->codec;
+ cc->workaround_bugs = FF_BUG_AUTODETECT;
+- if (videoStream == -1 && cc->codec_type==CODEC_TYPE_VIDEO) videoStream = i;
+- if (audioStream == -1 && cc->codec_type==CODEC_TYPE_AUDIO) audioStream = i;
++ if (videoStream == -1 && cc->codec_type==AVMEDIA_TYPE_VIDEO) videoStream = i;
++ if (audioStream == -1 && cc->codec_type==AVMEDIA_TYPE_AUDIO) audioStream = i;
+ }
+ if (videoStream == -1 && decodeVideo) throw std::runtime_error("No video stream found");
+ if (audioStream == -1 && decodeAudio) throw std::runtime_error("No audio stream found");
diff --git a/games-arcade/performous/files/performous-0.6.1-gentoo.patch b/games-arcade/performous/files/performous-0.6.1-gentoo.patch
new file mode 100644
index 000000000000..e9a6fe316b95
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.6.1-gentoo.patch
@@ -0,0 +1,29 @@
+--- game/CMakeLists.txt.old 2012-02-20 13:19:35.219635192 +0100
++++ game/CMakeLists.txt 2012-02-20 13:20:06.025469808 +0100
+@@ -149,5 +149,5 @@
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/config.cmake.hh" "${CMAKE_CURRENT_BINARY_DIR}/config.hh" @ONLY)
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}")
+
+-install(TARGETS performous DESTINATION bin)
++install(TARGETS performous DESTINATION @GENTOO_BINDIR@)
+
+--- game/fs.cc.old 2012-02-20 20:09:48.171892171 +0100
++++ game/fs.cc 2012-02-20 20:16:14.197400202 +0100
+@@ -195,6 +195,7 @@
+ if (root) config_list.push_back(std::string(root) + "/" SHARED_DATA_DIR + configFile.string());
+ fs::path exec = plugin::execname();
+ if (!exec.empty()) config_list.push_back(exec.parent_path().string() + "/../" SHARED_DATA_DIR + configFile.string());
++ config_list.push_back(SHARED_DATA_DIR + configFile.string());
+ ConfigList::const_iterator it = std::find_if(config_list.begin(), config_list.end(), static_cast<bool(&)(fs::path const&)>(fs::exists));
+ if (it == config_list.end()) {
+ throw std::runtime_error("Could not find default config file " + configFile.string());
+--- game/fs.cc.old 2012-02-20 20:49:35.610728056 +0100
++++ game/fs.cc 2012-02-20 20:57:03.117084432 +0100
+@@ -167,6 +167,7 @@
+
+ // Adding relative path from executable
+ dirs.push_back(plugin::execname().parent_path().parent_path() / shareDir);
++ dirs.push_back(shareDir);
+ #ifndef _WIN32
+ // Adding XDG_DATA_DIRS
+ {
diff --git a/games-arcade/performous/files/performous-0.6.1-libpng.patch b/games-arcade/performous/files/performous-0.6.1-libpng.patch
new file mode 100644
index 000000000000..2633e77c0fbb
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.6.1-libpng.patch
@@ -0,0 +1,11 @@
+--- game/image.hh.old 2012-02-19 09:20:09.215987761 +0100
++++ game/image.hh 2012-02-19 09:20:50.418077218 +0100
+@@ -26,7 +26,7 @@
+ }
+ void loadPNG_internal(png_structp pngPtr, png_infop infoPtr, std::ifstream& file, std::vector<unsigned char>& image, std::vector<png_bytep>& rows, unsigned& w, unsigned& h) {
+ if (setjmp(png_jmpbuf(pngPtr))) throw std::runtime_error("Reading PNG failed");
+- png_set_read_fn(pngPtr,(voidp)&file, readPngHelper);
++ png_set_read_fn(pngPtr,(png_voidp)&file, readPngHelper);
+ png_read_info(pngPtr, infoPtr);
+ png_set_expand(pngPtr); // Expand everything to RGB(A)
+ png_set_strip_16(pngPtr); // Strip everything down to 8 bit/component
diff --git a/games-arcade/performous/metadata.xml b/games-arcade/performous/metadata.xml
new file mode 100644
index 000000000000..7b9492fcc181
--- /dev/null
+++ b/games-arcade/performous/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ Performous is an open-source rhythm/performance platform that contains singing, guitar/bass playing, drumming and dancing all in one game.
+ </longdescription>
+ <use>
+ <flag name="songs">Install a few demo songs</flag>
+ <flag name="tools">Install tools</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-arcade/performous/performous-0.6.1.ebuild b/games-arcade/performous/performous-0.6.1.ebuild
new file mode 100644
index 000000000000..324939e179b1
--- /dev/null
+++ b/games-arcade/performous/performous-0.6.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/performous-0.6.1.ebuild,v 1.1 2012/02/21 20:51:12 tupone Exp $
+
+EAPI=3
+
+inherit flag-o-matic base cmake-utils games
+
+MY_PN=Performous
+MY_P=${MY_PN}-${PV}
+SONGS_PN=ultrastar-songs
+
+DESCRIPTION="SingStar GPL clone"
+HOMEPAGE="http://sourceforge.net/projects/performous/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-Source.tar.bz2
+ songs? (
+ mirror://sourceforge/${PN}/${SONGS_PN}-restricted-3.zip
+ mirror://sourceforge/${PN}/${SONGS_PN}-jc-1.zip
+ mirror://sourceforge/${PN}/${SONGS_PN}-libre-3.zip
+ mirror://sourceforge/${PN}/${SONGS_PN}-shearer-1.zip
+ )"
+
+LICENSE="GPL-2
+ songs? (
+ CCPL-Attribution-ShareAlike-NonCommercial-2.5
+ CCPL-Attribution-NonCommercial-NoDerivs-2.5
+ )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="songs tools"
+
+RDEPEND="dev-cpp/glibmm
+ dev-cpp/libxmlpp
+ media-libs/portaudio
+ dev-libs/boost
+ dev-libs/glib
+ dev-libs/libxml2
+ gnome-base/librsvg
+ media-gfx/imagemagick
+ virtual/jpeg
+ media-libs/libpng
+ media-libs/libsdl
+ virtual/opengl
+ virtual/glu
+ media-video/ffmpeg
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/pango
+ !games-arcade/ultrastar-ng"
+DEPEND="${RDEPEND}
+ media-libs/glew
+ sys-apps/help2man"
+
+S="${WORKDIR}"/${MY_P}-Source
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ffmpeg.patch
+ "${FILESDIR}"/${P}-libpng.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+DOCS="docs/{Author,DeveloperReadme,instruments,TODO}.txt"
+append-cppflags -DBOOST_FILESYSTEM_VERSION=2
+
+src_prepare() {
+ base_src_prepare
+ sed -i \
+ -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
+ game/CMakeLists.txt \
+ || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable tools TOOLS)
+ -DSHARE_INSTALL="${GAMES_DATADIR}"/${PN}
+ "
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use songs; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${S}/songs" || die "doins failed"
+ fi
+ prepgamesdirs
+}