summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-09-22 06:49:33 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-09-22 06:49:33 +0000
commit1f0f7ccfaf11b517d90dc3379f47620fa0f65086 (patch)
treeb452b0ba8743d0292f9d03e025d1149b09deee76 /games-arcade/sdlsasteroids
parentBump to latest 2.4 series and cleanup. (diff)
downloadgentoo-2-1f0f7ccfaf11b517d90dc3379f47620fa0f65086.tar.gz
gentoo-2-1f0f7ccfaf11b517d90dc3379f47620fa0f65086.tar.bz2
gentoo-2-1f0f7ccfaf11b517d90dc3379f47620fa0f65086.zip
Respect LDFLAGS. Bug #337920
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-arcade/sdlsasteroids')
-rw-r--r--games-arcade/sdlsasteroids/ChangeLog8
-rw-r--r--games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch11
-rw-r--r--games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild12
3 files changed, 23 insertions, 8 deletions
diff --git a/games-arcade/sdlsasteroids/ChangeLog b/games-arcade/sdlsasteroids/ChangeLog
index 2f854c9452d3..5968ff4b25b0 100644
--- a/games-arcade/sdlsasteroids/ChangeLog
+++ b/games-arcade/sdlsasteroids/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/sdlsasteroids
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/ChangeLog,v 1.8 2008/04/30 22:14:04 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/ChangeLog,v 1.9 2010/09/22 06:49:33 tupone Exp $
+
+ 22 Sep 2010; Tupone Alfredo <tupone@gentoo.org>
+ sdlsasteroids-3.0.1.ebuild, +files/sdlsasteroids-3.0.1-ldflags.patch:
+ Respect LDFLAGS. Bug #337920 by flameeyes@gentoo.org
30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+files/sdlsasteroids-3.0.1-gcc43.patch, sdlsasteroids-3.0.1.ebuild:
diff --git a/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch
new file mode 100644
index 000000000000..302c912efe18
--- /dev/null
+++ b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.old 2010-09-22 08:44:57.000000000 +0200
++++ src/Makefile 2010-09-22 08:45:43.000000000 +0200
+@@ -26,7 +26,7 @@
+
+
+ $(SASTEROIDS): $(SASTEROIDS_O)
+- g++ -Wall -o $(SASTEROIDS) $(SASTEROIDS_O) $(DEFINES) $(DEBUG) $(OPTS) $(CFLAGS) $(LIBS)
++ g++ $(LDFLAGS) -Wall -o $(SASTEROIDS) $(SASTEROIDS_O) $(DEFINES) $(DEBUG) $(OPTS) $(CFLAGS) $(LIBS)
+
+
+ .cpp.o:
diff --git a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
index ce0e6226c22f..69800280d2d6 100644
--- a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
+++ b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild,v 1.4 2008/04/30 22:14:04 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild,v 1.5 2010/09/22 06:49:33 tupone Exp $
+EAPI="2"
inherit eutils games
@@ -21,10 +22,9 @@ DEPEND="virtual/opengl
S=${WORKDIR}/SDLSasteroids-${PV}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
#-e '34 d' \
sed -i \
-e 's/make /$(MAKE) /' \