summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-22 10:21:38 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-22 10:21:38 +0000
commit86303241fc4966dc6f7214ee74c5f6a4f3d3fcc9 (patch)
tree17b2dc1ee157aa8116e538dc9d53c480efeb1364 /games-arcade/pydance
parentold (diff)
downloadgentoo-2-86303241fc4966dc6f7214ee74c5f6a4f3d3fcc9.tar.gz
gentoo-2-86303241fc4966dc6f7214ee74c5f6a4f3d3fcc9.tar.bz2
gentoo-2-86303241fc4966dc6f7214ee74c5f6a4f3d3fcc9.zip
ver bump #42219
Diffstat (limited to 'games-arcade/pydance')
-rw-r--r--games-arcade/pydance/ChangeLog9
-rw-r--r--games-arcade/pydance/files/digest-pydance-0.9.11
-rw-r--r--games-arcade/pydance/pydance-0.9.1.ebuild53
3 files changed, 61 insertions, 2 deletions
diff --git a/games-arcade/pydance/ChangeLog b/games-arcade/pydance/ChangeLog
index 7780a499ae98..4db41f8a6951 100644
--- a/games-arcade/pydance/ChangeLog
+++ b/games-arcade/pydance/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for games-arcade/pydance
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/ChangeLog,v 1.5 2004/01/14 17:40:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/ChangeLog,v 1.6 2004/02/22 10:21:38 vapier Exp $
+
+*pydance-0.9.1 (22 Feb 2004)
+
+ 22 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #42219 by Arnaud JEANSEN.
*pydance-0.8.4 (14 Jan 2004)
14 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
- Version bump #37661 Arnaud JEANSEN and Chris Aniszczyk.
+ Version bump #37661 by Arnaud JEANSEN and Chris Aniszczyk.
*pydance-0.8.2 (21 Nov 2003)
diff --git a/games-arcade/pydance/files/digest-pydance-0.9.1 b/games-arcade/pydance/files/digest-pydance-0.9.1
new file mode 100644
index 000000000000..34004c80a0fd
--- /dev/null
+++ b/games-arcade/pydance/files/digest-pydance-0.9.1
@@ -0,0 +1 @@
+MD5 71372469c6d66bce18a74a539b4fddbe pydance-0.9.1.tar.gz 5601735
diff --git a/games-arcade/pydance/pydance-0.9.1.ebuild b/games-arcade/pydance/pydance-0.9.1.ebuild
new file mode 100644
index 000000000000..a60ffd483bb3
--- /dev/null
+++ b/games-arcade/pydance/pydance-0.9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/pydance-0.9.1.ebuild,v 1.1 2004/02/22 10:21:38 vapier Exp $
+
+inherit games
+
+DESCRIPTION="pyDance is a DDR clone for linux written in Python"
+HOMEPAGE="http://www.icculus.org/pyddr/"
+SRC_URI="http://www.icculus.org/pyddr/${P}.tar.gz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND="dev-python/pygame
+ media-libs/libvorbis
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+PDEPEND="games-arcade/pydance-songs"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:/etc/:${GAMES_SYSCONFDIR}/:" \
+ constants.py docs/man/pydance.6 \
+ || die "sed failed"
+}
+
+src_install() {
+ local dir="${GAMES_DATADIR}/${PN}"
+
+ insinto ${dir}
+ doins *.py || die "doins failed"
+ cp -R {sound,images,utils,themes} "${D}${dir}/" || die "cp failed"
+
+ insinto ${GAMES_SYSCONFDIR}
+ newins pydance.posix.cfg pydance.cfg
+
+ games_make_wrapper pydance "python ./pydance.py" "${dir}"
+
+ dodoc BUGS CREDITS ChangeLog HACKING README TODO
+ dohtml docs/README.html
+ doman docs/man/*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "If you want to use a DDR pad with pyDance,"
+ einfo "all you need to do is emerge the games-arcade/ddrmat kernel module."
+}