summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-21 16:23:26 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-21 16:23:26 +0000
commit43897e14dfec7474c74a1ffb420c2a971172235d (patch)
tree73b62e9bd47ae47b693ce3168604a9b821cbe0d1 /games-arcade/monkey-bubble
parentLet it compile against glib-2.32 (diff)
downloadgentoo-2-43897e14dfec7474c74a1ffb420c2a971172235d.tar.gz
gentoo-2-43897e14dfec7474c74a1ffb420c2a971172235d.tar.bz2
gentoo-2-43897e14dfec7474c74a1ffb420c2a971172235d.zip
Let it compile against glib-2.32
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/monkey-bubble')
-rw-r--r--games-arcade/monkey-bubble/ChangeLog8
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch45
-rw-r--r--games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild8
3 files changed, 55 insertions, 6 deletions
diff --git a/games-arcade/monkey-bubble/ChangeLog b/games-arcade/monkey-bubble/ChangeLog
index 82ce3c6dc23b..2fc2efe818e9 100644
--- a/games-arcade/monkey-bubble/ChangeLog
+++ b/games-arcade/monkey-bubble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/monkey-bubble
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/ChangeLog,v 1.30 2012/03/17 20:39:30 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/ChangeLog,v 1.31 2012/07/21 16:23:26 pacho Exp $
+
+ 21 Jul 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/monkey-bubble-0.4.0-glib-single-include.patch,
+ monkey-bubble-0.4.0.ebuild:
+ Let it compile against glib-2.32
17 Mar 2012; Tupone Alfredo <tupone@gentoo.org> monkey-bubble-0.4.0.ebuild:
Add dependency on app-text/gnome-doc-utils. Should fix bug #408455 by
@@ -127,4 +132,3 @@
monkey-bubble-0.1.3.ebuild:
initial commit; ebuild modified from one submitted by Minati jean michel via
bug 29573
-
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch
new file mode 100644
index 000000000000..67109beff7f7
--- /dev/null
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch
@@ -0,0 +1,45 @@
+Index: monkey-bubble-0.4.0/src/net/message-handler.c
+===================================================================
+--- monkey-bubble-0.4.0.orig/src/net/message-handler.c
++++ monkey-bubble-0.4.0/src/net/message-handler.c
+@@ -28,7 +28,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <arpa/inet.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <sys/time.h>
+ #include <time.h>
+
+Index: monkey-bubble-0.4.0/src/net/simple-server.c
+===================================================================
+--- monkey-bubble-0.4.0.orig/src/net/simple-server.c
++++ monkey-bubble-0.4.0/src/net/simple-server.c
+@@ -31,13 +31,12 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <arpa/inet.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <sys/time.h>
+ #include <time.h>
+
+
+ #include <glib-object.h>
+-#include <glib.h>
+
+ #include "simple-server.h"
+ #include "message-handler.h"
+Index: monkey-bubble-0.4.0/src/ui/main.c
+===================================================================
+--- monkey-bubble-0.4.0.orig/src/ui/main.c
++++ monkey-bubble-0.4.0/src/ui/main.c
+@@ -15,7 +15,7 @@
+ #include <gtk/gtk.h>
+ #include <gst/gst.h>
+ #include <bonobo/bonobo-i18n.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <libgnomeui/gnome-ui-init.h>
+
+ #include <math.h>
diff --git a/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild b/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild
index b62faee86cb2..19c1013d15ac 100644
--- a/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild
+++ b/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild,v 1.11 2012/03/17 20:39:30 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild,v 1.12 2012/07/21 16:23:26 pacho Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils gnome2
DESCRIPTION="A Puzzle Bobble clone"
@@ -31,7 +31,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-asneeded.patch \
"${FILESDIR}"/${P}-gnome-doc.patch \
- "${FILESDIR}"/${P}-noesound.patch
+ "${FILESDIR}"/${P}-noesound.patch \
+ "${FILESDIR}"/${P}-glib-single-include.patch
# bug 260895
sed -i \
-e 's/ -Werror//' \
@@ -39,5 +40,4 @@ src_prepare() {
|| die "sed failed"
AT_NOELIBTOOLIZE=yes eautoreconf
gnome2_src_prepare
- intltoolize --force || die "intltoolize failed" #bug 180458
}