summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-06-14 18:16:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-06-14 18:16:59 +0000
commit66c0accbce1efa513fb36f6590bd8aed79a749d1 (patch)
tree256d7d31671f31420827a66e2cb2563d5cf3090a /games-arcade/berusky
parent[bump] dev-perl/Lingua-EN-Inflect-1.894.0 (diff)
downloadgentoo-2-66c0accbce1efa513fb36f6590bd8aed79a749d1.tar.gz
gentoo-2-66c0accbce1efa513fb36f6590bd8aed79a749d1.tar.bz2
gentoo-2-66c0accbce1efa513fb36f6590bd8aed79a749d1.zip
version bump with all the work done by Michael Palimaka (bug #394555)
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/berusky')
-rw-r--r--games-arcade/berusky/ChangeLog10
-rw-r--r--games-arcade/berusky/berusky-1.4.ebuild41
-rw-r--r--games-arcade/berusky/files/berusky-1.4-gentoo.patch71
3 files changed, 120 insertions, 2 deletions
diff --git a/games-arcade/berusky/ChangeLog b/games-arcade/berusky/ChangeLog
index a5e62ffe76d8..5764e3241130 100644
--- a/games-arcade/berusky/ChangeLog
+++ b/games-arcade/berusky/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/berusky
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/berusky/ChangeLog,v 1.4 2010/10/27 08:44:12 tupone Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/berusky/ChangeLog,v 1.5 2012/06/14 18:16:59 mr_bones_ Exp $
+
+*berusky-1.4 (14 Jun 2012)
+
+ 14 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> +berusky-1.4.ebuild,
+ +files/berusky-1.4-gentoo.patch:
+ version bump with all the work done by Michael Palimaka (bug #394555)
27 Oct 2010; Tupone Alfredo <tupone@gentoo.org> berusky-1.1.ebuild,
+files/berusky-1.1-ovflfix.patch:
diff --git a/games-arcade/berusky/berusky-1.4.ebuild b/games-arcade/berusky/berusky-1.4.ebuild
new file mode 100644
index 000000000000..c2eb37b62d47
--- /dev/null
+++ b/games-arcade/berusky/berusky-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/berusky/berusky-1.4.ebuild,v 1.1 2012/06/14 18:16:59 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DATAFILE=${PN}-data-${PV}
+DESCRIPTION="free logic game based on an ancient puzzle named Sokoban."
+HOMEPAGE="http://anakreon.cz/?q=node/1"
+SRC_URI="http://www.anakreon.cz/download/${P}.tar.gz
+ http://www.anakreon.cz/download/${DATAFILE}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+
+src_prepare() {
+ mv ../${DATAFILE}/{berusky.ini,GameData,Graphics,Levels} . \
+ || die "failed moving data"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
+ src/defines.h berusky.ini \
+ || die "sed for patching path failed"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r berusky.ini GameData Graphics Levels \
+ || die "failed installing data"
+ make_desktop_entry ${PN}
+ prepgamesdirs
+}
diff --git a/games-arcade/berusky/files/berusky-1.4-gentoo.patch b/games-arcade/berusky/files/berusky-1.4-gentoo.patch
new file mode 100644
index 000000000000..1b8b09c1d2b6
--- /dev/null
+++ b/games-arcade/berusky/files/berusky-1.4-gentoo.patch
@@ -0,0 +1,71 @@
+--- src/defines.h
++++ src/defines.h
+@@ -405,7 +405,7 @@
+ #ifdef LINUX
+ #define INI_USER_DIRECTORY "~/.berusky"
+ #define INI_USER_LEVELS "~/.berusky/User"
+-#define INI_FILE_GLOBAL "/var/games/berusky/"INI_FILE_NAME
++#define INI_FILE_GLOBAL "@GENTOO_DATADIR@/"INI_FILE_NAME
+ #define INI_FILE_USER "~/.berusky/"INI_FILE_NAME
+ #define INI_FILE_LOCAL "./"INI_FILE_NAME
+ #elif WINDOWS
+--- berusky.ini
++++ berusky.ini
+@@ -1,9 +1,9 @@
+ # Configuration for berusky game
+
+ # Game data location
+-level_data = /usr/share/berusky/Levels
+-game_data = /usr/share/berusky/GameData
+-graphics_data = /usr/share/berusky/Graphics
++level_data = @GENTOO_DATADIR@/Levels
++game_data = @GENTOO_DATADIR@/GameData
++graphics_data = @GENTOO_DATADIR@/Graphics
+
+ # Graphics settings for game and editor
+ # game runs in 640x480
+@@ -17,7 +17,7 @@
+
+ # Game binary & tmp dir
+ # they're used by editor for "run level" command
+-game_binary = /usr/bin/berusky
++game_binary = @GENTOO_BINDIR@/berusky
+ tmp_data = /var/tmp
+
+ # Dir for users levels (it's the default level dir for level editor)
+--- data/Makefile.am
++++ data/Makefile.am
+@@ -4,9 +4,6 @@
+ ## If you don't want it to overwrite it,
+ ## Please disable it in the Anjuta project configuration
+
+-berusky_datadir = $(prefix)/@NO_PREFIX_PACKAGE_DATA_DIR@/@PACKAGE@
+-
+-berusky_data_DATA = \
+- berusky.ini
+-
+-EXTRA_DIST = $(berusky_data_DATA)
++EXTRA_DIST = \
++ berusky-data.spec\
++ berusky.spec
+--- Makefile.am
++++ Makefile.am
+@@ -5,8 +5,7 @@
+
+ SUBDIRS = po src data
+
+-beruskydocdir = ${prefix}/doc/berusky
+-beruskydoc_DATA = \
++EXTRA_DIST = \
+ README\
+ COPYING\
+ AUTHORS\
+@@ -15,8 +14,6 @@
+ NEWS\
+ TODO
+
+-EXTRA_DIST = $(beruskydoc_DATA)
+-
+ # Copy all the spec files. Of cource, only one is actually used.
+ dist-hook:
+ for specfile in *.spec; do \