summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-15 21:00:29 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-15 21:00:29 +0000
commite9069fcaa131ac5cf3813d5780e68e3b0bad0a69 (patch)
treec202a3688df46a303574690a4352b395a7351444 /games-arcade/abe
parentFixed broken package.mask (diff)
downloadgentoo-2-e9069fcaa131ac5cf3813d5780e68e3b0bad0a69.tar.gz
gentoo-2-e9069fcaa131ac5cf3813d5780e68e3b0bad0a69.tar.bz2
gentoo-2-e9069fcaa131ac5cf3813d5780e68e3b0bad0a69.zip
Install menu entry, bug #159771
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-arcade/abe')
-rw-r--r--games-arcade/abe/ChangeLog7
-rw-r--r--games-arcade/abe/abe-1.1.ebuild15
2 files changed, 14 insertions, 8 deletions
diff --git a/games-arcade/abe/ChangeLog b/games-arcade/abe/ChangeLog
index c5a40e043a7e..51e19e794568 100644
--- a/games-arcade/abe/ChangeLog
+++ b/games-arcade/abe/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/abe
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/abe/ChangeLog,v 1.6 2006/09/20 16:47:12 blubb Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/abe/ChangeLog,v 1.7 2007/03/15 21:00:29 nyhm Exp $
+
+ 15 Mar 2007; Tristan Heaven <nyhm@gentoo.org> abe-1.1.ebuild:
+ Install menu entry, bug #159771
20 Sep 2006; <blubb@gentoo.org> abe-1.1.ebuild:
stable on amd64
diff --git a/games-arcade/abe/abe-1.1.ebuild b/games-arcade/abe/abe-1.1.ebuild
index 940da2e921d1..517bc0a8c03b 100644
--- a/games-arcade/abe/abe-1.1.ebuild
+++ b/games-arcade/abe/abe-1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/abe/abe-1.1.ebuild,v 1.3 2006/10/17 17:56:28 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/abe/abe-1.1.ebuild,v 1.4 2007/03/15 21:00:29 nyhm Exp $
inherit eutils toolchain-funcs games
@@ -13,8 +13,8 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.2.3
- >=media-libs/sdl-mixer-1.2.5"
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer"
src_unpack() {
unpack ${A}
@@ -24,17 +24,20 @@ src_unpack() {
-e "/^TR_CXXFLAGS/d" \
configure \
|| die "sed failed"
+ unpack ./images/images.tar
}
src_compile() {
- egamesconf --with-data-dir="${GAMES_DATADIR}/${PN}" || die
+ egamesconf --with-data-dir="${GAMES_DATADIR}"/${PN} || die
emake CC=$(tc-getCC) || die "emake failed"
}
src_install() {
dogamesbin src/abe || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
+ insinto "${GAMES_DATADIR}"/${PN}
doins -r images sounds maps || die "doins failed"
+ newicon tom1.bmp abe.bmp
+ make_desktop_entry abe "Abe's Amazing Adventure" /usr/share/pixmaps/abe.bmp
dodoc AUTHORS ChangeLog README
prepgamesdirs
}