summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-25 13:01:28 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-25 13:01:28 +0000
commitf1b7481e680eb2840201cd60397d681761e0cb3b (patch)
treea4ae89ae8aa6dbd1ba3f2350b4eab0d5221fa39f /games-action
parentFixed bug from http://forums.gentoo.org/viewtopic-t-542641.html (diff)
downloadgentoo-2-f1b7481e680eb2840201cd60397d681761e0cb3b.tar.gz
gentoo-2-f1b7481e680eb2840201cd60397d681761e0cb3b.tar.bz2
gentoo-2-f1b7481e680eb2840201cd60397d681761e0cb3b.zip
use doins
(Portage version: 2.1.2-r11)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/chickens/chickens-0.2.4.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/games-action/chickens/chickens-0.2.4.ebuild b/games-action/chickens/chickens-0.2.4.ebuild
index 9e4244dcbfba..13ac619fc2b4 100644
--- a/games-action/chickens/chickens-0.2.4.ebuild
+++ b/games-action/chickens/chickens-0.2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chickens/chickens-0.2.4.ebuild,v 1.9 2006/09/20 16:42:42 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/chickens/chickens-0.2.4.ebuild,v 1.10 2007/02/25 13:01:28 nyhm Exp $
inherit games
@@ -16,7 +16,7 @@ IUSE=""
DEPEND="media-libs/allegro"
-S=${WORKDIR}/chickens
+S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
@@ -31,19 +31,18 @@ src_unpack() {
-e "s:\"sound/:\"${GAMES_DATADIR}/${PN}/sound/:" \
-e "s:\"dat/:\"${GAMES_DATADIR}/${PN}/dat/:" main.cpp README \
|| die "sed failed"
- chmod a-x {dat,sound}/*
+ sed -i '/^CPPFLAGS/d' configure || die "sed failed"
}
src_install() {
- dogamesbin chickens || die "dogamesbin failed"
- dodir "${GAMES_DATADIR}/${PN}"
- cp -r {dat,sound} "${D}/${GAMES_DATADIR}/${PN}" \
- || die "cp failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r dat sound || die "doins failed"
dodoc AUTHOR README
- insinto "${GAMES_STATEDIR}/${PN}"
+ insinto "${GAMES_STATEDIR}"/${PN}
doins HighScores || die "doins failed"
- insinto "${GAMES_SYSCONFDIR}/${PN}"
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
doins options.cfg || die "doins failed"
- fperms g+w "${GAMES_STATEDIR}/${PN}/HighScores"
+ fperms g+w "${GAMES_STATEDIR}"/${PN}/HighScores
prepgamesdirs
}