summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2004-11-01 09:32:52 +0000
committerJoseph Jezak <josejx@gentoo.org>2004-11-01 09:32:52 +0000
commitefe63f587c1d68332376498076e27ad90f62d736 (patch)
tree0741095c4f02ede31db3efb2c60798d37dfce0e3 /games-action
parent~alpha keyword. (Manifest recommit) (diff)
downloadgentoo-2-efe63f587c1d68332376498076e27ad90f62d736.tar.gz
gentoo-2-efe63f587c1d68332376498076e27ad90f62d736.tar.bz2
gentoo-2-efe63f587c1d68332376498076e27ad90f62d736.zip
GCC 3.4 fixes, marked ~ppc
Diffstat (limited to 'games-action')
-rw-r--r--games-action/koth/ChangeLog6
-rw-r--r--games-action/koth/Manifest5
-rw-r--r--games-action/koth/files/koth-0.8.0-gcc-3.4.patch29
-rw-r--r--games-action/koth/koth-0.8.0.ebuild10
4 files changed, 45 insertions, 5 deletions
diff --git a/games-action/koth/ChangeLog b/games-action/koth/ChangeLog
index feab63876fd8..ca66825ea1f6 100644
--- a/games-action/koth/ChangeLog
+++ b/games-action/koth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/koth
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/koth/ChangeLog,v 1.7 2004/06/24 21:56:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/koth/ChangeLog,v 1.8 2004/11/01 09:32:51 josejx Exp $
+
+ 01 Nov 2004; Joseph Jezak <josejx@gentoo.org>
+ +files/koth-0.8.0-gcc-3.4.patch, koth-0.8.0.ebuild:
+ GCC 3.4 fixes and marked ~ppc
01 Jun 2004; Chris Gianelloni <wolf31o2@gentoo.org> koth-0.8.0.ebuild:
Marking stable on alpha (no bugs in 478 days).
diff --git a/games-action/koth/Manifest b/games-action/koth/Manifest
index aa5e05a70aa9..7e97b279b3bf 100644
--- a/games-action/koth/Manifest
+++ b/games-action/koth/Manifest
@@ -1,6 +1,7 @@
+MD5 c81b3bd366bbc406736f2d46118a5b28 ChangeLog 1448
MD5 9cdd71197af50cc9ec86f9023d5c40dd koth-0.7.7.ebuild 742
-MD5 2ab699279c0ff634eca1b97f43958f60 koth-0.8.0.ebuild 754
-MD5 fbd25d244967fa3dd3c48b017120b33a ChangeLog 1313
+MD5 9c0d4ba99f0405ec2906c6889065ce83 koth-0.8.0.ebuild 847
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 74ab215bb3829c3e46c82a7607b6fa55 files/digest-koth-0.7.7 63
MD5 639b4734a76c78db41e4ef7db6587fd1 files/digest-koth-0.8.0 63
+MD5 8ad7c4c5d637f02056ba07416f3696a0 files/koth-0.8.0-gcc-3.4.patch 612
diff --git a/games-action/koth/files/koth-0.8.0-gcc-3.4.patch b/games-action/koth/files/koth-0.8.0-gcc-3.4.patch
new file mode 100644
index 000000000000..4a858cbe03a9
--- /dev/null
+++ b/games-action/koth/files/koth-0.8.0-gcc-3.4.patch
@@ -0,0 +1,29 @@
+--- relay.c.old 2004-11-01 09:19:04.835537536 +0000
++++ relay.c 2004-11-01 09:19:59.453234384 +0000
+@@ -260,6 +260,7 @@
+ else goto bail;
+ goto nextpkt;
+ bail:
++ ;
+ }
+ }
+ }
+--- ballistics.c.old 2004-11-01 09:19:33.132235784 +0000
++++ ballistics.c 2004-11-01 09:20:16.849589736 +0000
+@@ -92,6 +92,7 @@
+ break;
+ case WALL_LAST:
+ /* just to satisfy gcc -Wall */
++ ;
+ }
+ }
+
+@@ -210,7 +211,7 @@
+ break;
+ case WALL_RANDOM: /* both of this can't happen, */
+ case WALL_LAST: /* so they are here to satisfy gcc -Wall */
+-
++ ;
+ }
+ }
+ return FLYING;
diff --git a/games-action/koth/koth-0.8.0.ebuild b/games-action/koth/koth-0.8.0.ebuild
index 6f9b3e821712..cd220e0ea7b2 100644
--- a/games-action/koth/koth-0.8.0.ebuild
+++ b/games-action/koth/koth-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation and Arcady Genkin <agenkin@thpoon.com>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/koth/koth-0.8.0.ebuild,v 1.8 2004/06/24 21:56:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/koth/koth-0.8.0.ebuild,v 1.9 2004/11/01 09:32:51 josejx Exp $
inherit eutils
@@ -10,11 +10,17 @@ SRC_URI="http://savannah.nongnu.org/download/${PN}/default.pkg/${PV}/${P}.tar.bz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 alpha ~amd64"
+KEYWORDS="x86 alpha ~amd64 ~ppc"
IUSE=""
DEPEND="media-libs/libggi"
+src_unpack(){
+ unpack ${A}
+ cd ${S}/src
+ epatch ${FILESDIR}/koth-0.8.0-gcc-3.4.patch
+}
+
src_install() {
dodir /usr/bin
make DESTDIR=${D} install || die "make install failed"