summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-29 16:43:35 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-29 16:43:35 +0000
commite5adc2977335ec499afa979b2b3f900c1c47ffd5 (patch)
tree34e7e056e1e15c2261e716a1f42c4618fc70fad9 /games-action
parentChanged DEPEND/RDEPEND to newdepend/newrdepend (diff)
downloadgentoo-2-e5adc2977335ec499afa979b2b3f900c1c47ffd5.tar.gz
gentoo-2-e5adc2977335ec499afa979b2b3f900c1c47ffd5.tar.bz2
gentoo-2-e5adc2977335ec499afa979b2b3f900c1c47ffd5.zip
old
Diffstat (limited to 'games-action')
-rw-r--r--games-action/armagetron/armagetron-0.2.4-r1.ebuild67
-rw-r--r--games-action/armagetron/armagetron-0.2.5.1.ebuild62
-rw-r--r--games-action/armagetron/files/digest-armagetron-0.2.4-r14
-rw-r--r--games-action/armagetron/files/digest-armagetron-0.2.5.14
4 files changed, 0 insertions, 137 deletions
diff --git a/games-action/armagetron/armagetron-0.2.4-r1.ebuild b/games-action/armagetron/armagetron-0.2.4-r1.ebuild
deleted file mode 100644
index 306351783dd9..000000000000
--- a/games-action/armagetron/armagetron-0.2.4-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.2.4-r1.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
-
-inherit games
-
-IUSE="`echo " ${IUSE} " | sed 's/ dedicated //'`"
- # drop 'dedicated' as it is always enabled
-
-S=${WORKDIR}/${PN}-${PV}
-DESCRIPTION="armagetron: 3d tron lightcycles, just like the movie"
-SRC_URI="mirror://sourceforge/armagetron/${P}.tar.bz2
- http://armagetron.sourceforge.net/addons/moviesounds_fq.zip
- http://armagetron.sourceforge.net/addons/moviepack.zip"
-
-HOMEPAGE="http://armagetron.sourceforge.net/"
-KEYWORDS="x86 ppc"
-LICENSE="GPL-2"
-SLOT="0"
-CXXFLAGS=${CXXFLAGS/-fno-exceptions/}
-RDEPEND="virtual/x11
- virtual/opengl
- media-libs/libsdl
- media-libs/sdl-image
- sys-libs/zlib
- media-libs/libpng"
-
-DEPEND="$RDEPEND app-arch/unzip"
-
-src_unpack() {
- unpack ${PN}-${PV}.tar.bz2
- unpack moviesounds_fq.zip
- unpack moviepack.zip
- set > /tmp/emerge-env.txt
- cd ${S}
- # Uses $SYNC which which conflicts with emerge
- cp Makefile.global.in Makefile.global.in.old
- sed 's/$(SYNC)/$(SYNCDISK)/' < Makefile.global.in.old > \
- Makefile.global.in || die 'Makefile edit failed'
-}
-
-src_compile() {
- egamesconf || die "config failed"
- emake || die "Make Failed"
-}
-
-src_install () {
- # make install for armagetron is non-existant
- dodir ${GAMES_BINDIR}
- dodir ${GAMES_LIBDIR}/${PN}
- dodir ${GAMES_DATADIR}/${PN}
- dodir /usr/share/fonts
- cp src/tron/armagetron ${D}/${GAMES_LIBDIR}/${PN} || die "No Armagetron Executable"
- cp -r arenas models sound textures language config \
- ${D}/${GAMES_DATADIR}/${PN}/
- # maybe convert this to a .png or something
- #cp tron.ico ${D}/${GAMES_DATADIR}/${PN}
- dohtml doc
- newgamesbin ${FILESDIR}/${P}-r1.sh ${PN}
- dosed "s:DATADIR:${GAMES_DATADIR}/${PN}:" ${GAMES_BINDIR}/${PN}
- dosed "s:BINDIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/${PN}
- cp -r ../moviepack ${D}/${GAMES_DATADIR}/${PN}
- cp -r ../moviesounds ${D}/${GAMES_DATADIR}/${PN}
- chmod -R a+r ${D}
- chmod a+rx ${D}/${GAMES_BINDIR}/${PN}
- chmod a+rx ${D}/${GAMES_LIBDIR}/${PN}/${PN}
-}
diff --git a/games-action/armagetron/armagetron-0.2.5.1.ebuild b/games-action/armagetron/armagetron-0.2.5.1.ebuild
deleted file mode 100644
index fd43359828a5..000000000000
--- a/games-action/armagetron/armagetron-0.2.5.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.2.5.1.ebuild,v 1.2 2003/10/28 14:10:22 vapier Exp $
-
-inherit games
-
-IUSE="`echo " ${IUSE} " | sed 's/ dedicated //'`"
-
-S=${WORKDIR}/${PN}-${PV}
-DESCRIPTION="armagetron: 3d tron lightcycles, just like the movie"
-SRC_URI="mirror://sourceforge/armagetron/${P}.tar.bz2
- http://armagetron.sourceforge.net/addons/moviesounds_fq.zip
- http://armagetron.sourceforge.net/addons/moviepack.zip"
-HOMEPAGE="http://armagetron.sourceforge.net/"
-KEYWORDS="x86 ppc"
-LICENSE="GPL-2"
-SLOT="0"
-CXXFLAGS=${CXXFLAGS/-fno-exceptions/}
-RDEPEND="virtual/x11
- virtual/opengl
- media-libs/libsdl
- media-libs/sdl-image
- sys-libs/zlib
- media-libs/libpng"
-
-DEPEND="$RDEPEND
- >=sys-apps/sed-4
- app-arch/unzip"
-
-src_unpack() {
- unpack ${PN}-${PV}.tar.bz2
- unpack moviesounds_fq.zip
- unpack moviepack.zip
- set > /tmp/emerge-env.txt
- cd ${S}
- # Uses $SYNC which which conflicts with emerge
- sed -i \
- -e 's/$(SYNC)/$(SYNCDISK)/' Makefile.global.in || \
- die 'sed Makefile.global.in failed'
-}
-
-src_install () {
- # make install for armagetron is non-existant
- dodir ${GAMES_BINDIR}
- dodir ${GAMES_LIBDIR}/${PN}
- dodir ${GAMES_DATADIR}/${PN}
- dodir /usr/share/fonts
- cp src/tron/armagetron ${D}/${GAMES_LIBDIR}/${PN} || die "No Armagetron Executable"
- cp -r arenas models sound textures language config \
- ${D}/${GAMES_DATADIR}/${PN}/ || die "Missing ArmageTRON data"
- # maybe convert this to a .png or something
- #cp tron.ico ${D}/${GAMES_DATADIR}/${PN}
- dohtml doc
- newgamesbin ${FILESDIR}/${PN}-0.2.4-r1.sh ${PN} || die "ArmageTRON shell script not found"
- dosed "s:DATADIR:${GAMES_DATADIR}/${PN}:" ${GAMES_BINDIR}/${PN}
- dosed "s:BINDIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/${PN}
- cp -r ../moviepack ${D}/${GAMES_DATADIR}/${PN}
- cp -r ../moviesounds ${D}/${GAMES_DATADIR}/${PN}
- chmod -R a+r ${D}
- chmod a+rx ${D}/${GAMES_BINDIR}/${PN}
- chmod a+rx ${D}/${GAMES_LIBDIR}/${PN}/${PN}
-}
diff --git a/games-action/armagetron/files/digest-armagetron-0.2.4-r1 b/games-action/armagetron/files/digest-armagetron-0.2.4-r1
deleted file mode 100644
index f5c6c8b401b1..000000000000
--- a/games-action/armagetron/files/digest-armagetron-0.2.4-r1
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 96d2388100c31ef915f48af19f275de1 armagetron-0.2.4.tar.bz2 1012151
-MD5 3c5d04af52eb296cdeb2fba5ecbd8899 moviesounds_fq.zip 2182021
-MD5 e2d40309dde7e1339ca6aff7599cdfa3 moviepack.zip 352253
-MD5 008bd26c244d2026d2be7658a8059ba1 Omikron.ttf 31832
diff --git a/games-action/armagetron/files/digest-armagetron-0.2.5.1 b/games-action/armagetron/files/digest-armagetron-0.2.5.1
deleted file mode 100644
index 36eafb276393..000000000000
--- a/games-action/armagetron/files/digest-armagetron-0.2.5.1
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 99c1a776691362108911bbd67e4a27c8 armagetron-0.2.5.1.tar.bz2 1027602
-MD5 3c5d04af52eb296cdeb2fba5ecbd8899 moviesounds_fq.zip 2182021
-MD5 e2d40309dde7e1339ca6aff7599cdfa3 moviepack.zip 352253
-MD5 008bd26c244d2026d2be7658a8059ba1 Omikron.ttf 31832