summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-07-25 07:00:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-07-25 07:00:23 +0000
commitc4ec19de527f32ea43b2aea6ed7cc14b1d3be5d7 (patch)
treefbcac33467bd928123bf7ce1dbbdf4d7e9779862 /games-action
parentBump to 3.5.4 (pre-release). (diff)
downloadgentoo-2-c4ec19de527f32ea43b2aea6ed7cc14b1d3be5d7.tar.gz
gentoo-2-c4ec19de527f32ea43b2aea6ed7cc14b1d3be5d7.tar.bz2
gentoo-2-c4ec19de527f32ea43b2aea6ed7cc14b1d3be5d7.zip
warn if mikmod USE flag isn't set
(Portage version: 2.1.1_pre3-r4)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/gltron/gltron-0.70-r1.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/games-action/gltron/gltron-0.70-r1.ebuild b/games-action/gltron/gltron-0.70-r1.ebuild
index 3e6938bd15e2..468e4b08e4a9 100644
--- a/games-action/gltron/gltron-0.70-r1.ebuild
+++ b/games-action/gltron/gltron-0.70-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.3 2006/03/09 18:14:39 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.4 2006/07/25 07:00:23 mr_bones_ Exp $
inherit eutils games
@@ -23,9 +23,9 @@ DEPEND="virtual/opengl
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-configure.patch
- epatch "${FILESDIR}"/${P}-prototypes.patch
- epatch "${FILESDIR}"/${P}-debian.patch
+ epatch "${FILESDIR}"/${P}-configure.patch \
+ "${FILESDIR}"/${P}-prototypes.patch \
+ "${FILESDIR}"/${P}-debian.patch
}
src_compile() {
@@ -47,3 +47,13 @@ src_install() {
make_desktop_entry ${PN} GLtron ${PN}.png
prepgamesdirs
}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ if ! use mikmod ; then
+ echo
+ ewarn "Since you don't have the mikmod USE flag set, there won't"
+ ewarn "be any in-game music for ${PN}."
+ fi
+}