summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-20 07:32:12 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-20 07:32:12 +0000
commitc2962c344fe674c90bdf5ea524a22fe4ee5180f3 (patch)
treebcc0033d663cc51e6e6da7e0d9a857d52618e73c /games-action
parentRespecting LDFLAGS, linking correctly, #247931 & #343339; More config options... (diff)
downloadgentoo-2-c2962c344fe674c90bdf5ea524a22fe4ee5180f3.tar.gz
gentoo-2-c2962c344fe674c90bdf5ea524a22fe4ee5180f3.tar.bz2
gentoo-2-c2962c344fe674c90bdf5ea524a22fe4ee5180f3.zip
Build with gcc-4.6 Bug #362829
(Portage version: 2.1.9.46/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/btanks/ChangeLog8
-rw-r--r--games-action/btanks/btanks-0.9.8083.ebuild7
-rw-r--r--games-action/btanks/files/btanks-0.9.8083-gcc46.patch10
3 files changed, 20 insertions, 5 deletions
diff --git a/games-action/btanks/ChangeLog b/games-action/btanks/ChangeLog
index 0b4f7bfb690c..432222e63365 100644
--- a/games-action/btanks/ChangeLog
+++ b/games-action/btanks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/btanks
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.23 2010/10/14 03:52:04 mr_bones_ Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.24 2011/04/20 07:32:12 tupone Exp $
+
+ 20 Apr 2011; Tupone Alfredo <tupone@gentoo.org> btanks-0.9.8083.ebuild,
+ +files/btanks-0.9.8083-gcc46.patch:
+ Build with gcc-4.6 Bug #362829 by Diego Elio Pettenò
14 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org>
btanks-0.9.8083.ebuild:
diff --git a/games-action/btanks/btanks-0.9.8083.ebuild b/games-action/btanks/btanks-0.9.8083.ebuild
index d87b56d6c1cd..bdc84f4d6957 100644
--- a/games-action/btanks/btanks-0.9.8083.ebuild
+++ b/games-action/btanks/btanks-0.9.8083.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.9.8083.ebuild,v 1.3 2010/10/14 03:52:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.9.8083.ebuild,v 1.4 2011/04/20 07:32:12 tupone Exp $
EAPI=2
inherit eutils scons-utils games
@@ -27,7 +27,8 @@ DEPEND="${RDEPEND}
src_prepare() {
rm -rf sdlx/gfx
- epatch "${FILESDIR}"/${P}-scons-blows.patch
+ epatch "${FILESDIR}"/${P}-scons-blows.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
}
src_compile() {
diff --git a/games-action/btanks/files/btanks-0.9.8083-gcc46.patch b/games-action/btanks/files/btanks-0.9.8083-gcc46.patch
new file mode 100644
index 000000000000..367c33cc6f24
--- /dev/null
+++ b/games-action/btanks/files/btanks-0.9.8083-gcc46.patch
@@ -0,0 +1,10 @@
+--- engine/sl08/sl08.h.old 2011-04-19 17:20:34.055776870 +0200
++++ engine/sl08/sl08.h 2011-04-19 17:20:59.471398921 +0200
+@@ -22,6 +22,7 @@
+ /* DO NOT MODIFY THIS FILE: IT'S AUTOGENERATED */
+
+ #include <list>
++#include <cstddef>
+
+ #ifndef NULL
+ #define NULL ((void*) 0)