summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-11-06 08:53:50 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-11-06 08:53:50 +0000
commitad8b7632aaa931924e22ac03cf7f237f725dd90b (patch)
tree25ba1be3d7f1f4e0e5bd1381c40f7bcdb54c623d /games-action
parentVersion bump. (diff)
downloadgentoo-2-ad8b7632aaa931924e22ac03cf7f237f725dd90b.tar.gz
gentoo-2-ad8b7632aaa931924e22ac03cf7f237f725dd90b.tar.bz2
gentoo-2-ad8b7632aaa931924e22ac03cf7f237f725dd90b.zip
Build with boost-1.50 Bug #425454
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/violetland/ChangeLog6
-rw-r--r--games-action/violetland/files/violetland-0.4.3-boost150.patch41
-rw-r--r--games-action/violetland/violetland-0.4.3.ebuild25
3 files changed, 54 insertions, 18 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
index 200442b3ad89..380b5c0455ea 100644
--- a/games-action/violetland/ChangeLog
+++ b/games-action/violetland/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/violetland
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.24 2012/08/29 04:23:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.25 2012/11/06 08:53:49 tupone Exp $
+
+ 06 Nov 2012; Tupone Alfredo <tupone@gentoo.org> violetland-0.4.3.ebuild,
+ +files/violetland-0.4.3-boost150.patch:
+ Build with boost-1.50 Bug #425454 by Diego
29 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> violetland-0.4.3.ebuild:
limit boost to the versions that work
diff --git a/games-action/violetland/files/violetland-0.4.3-boost150.patch b/games-action/violetland/files/violetland-0.4.3-boost150.patch
new file mode 100644
index 000000000000..4e700ca9e3d4
--- /dev/null
+++ b/games-action/violetland/files/violetland-0.4.3-boost150.patch
@@ -0,0 +1,41 @@
+--- CMakeLists.txt.old 2012-11-05 15:19:11.501044743 +0100
++++ CMakeLists.txt 2012-11-05 15:19:25.415250207 +0100
+@@ -8,7 +8,6 @@
+ find_package(SDL_mixer REQUIRED)
+ find_package(OpenGL REQUIRED)
+ find_package(Boost COMPONENTS filesystem system REQUIRED)
+-add_definitions(-DBOOST_FILESYSTEM_VERSION=2)
+
+ if(${MINGW})
+ set(INTL_LIBRARY intl)
+--- src/system/utility/FileUtility.cpp.old 2012-11-05 21:26:07.865488297 +0100
++++ src/system/utility/FileUtility.cpp 2012-11-05 21:30:44.881208230 +0100
+@@ -20,7 +20,7 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_regular_file(*dir_it))
+- files.push_back(dir_it->filename());
++ files.push_back(dir_it->path().filename().string());
+ ++dir_it;
+ }
+ return files;
+@@ -32,8 +32,8 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_directory(*dir_it))
+- if (dir_it->path().filename()[0] != '.')
+- subDirs.push_back(dir_it->path().filename());
++ if (dir_it->path().filename().string()[0] != '.')
++ subDirs.push_back(dir_it->path().filename().string());
+ ++dir_it;
+ }
+ return subDirs;
+@@ -45,7 +45,7 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_directory(*dir_it))
+- if (dir_it->path().filename()[0] != '.')
++ if (dir_it->path().filename().string()[0] != '.')
+ ++count;
+ ++dir_it;
+ }
diff --git a/games-action/violetland/violetland-0.4.3.ebuild b/games-action/violetland/violetland-0.4.3.ebuild
index 00a44d27d43a..66ce07572fed 100644
--- a/games-action/violetland/violetland-0.4.3.ebuild
+++ b/games-action/violetland/violetland-0.4.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.4.3.ebuild,v 1.4 2012/08/29 04:23:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.4.3.ebuild,v 1.5 2012/11/06 08:53:49 tupone Exp $
EAPI=2
-inherit eutils multilib toolchain-funcs flag-o-matic cmake-utils games
+inherit eutils multilib toolchain-funcs flag-o-matic boost-utils cmake-utils games
DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
HOMEPAGE="http://code.google.com/p/violetland/"
@@ -18,8 +18,7 @@ RDEPEND="media-libs/libsdl[audio,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-ttf
- <dev-libs/boost-1.50
- >=dev-libs/boost-1.37
+ dev-libs/boost
virtual/opengl
virtual/glu"
DEPEND="${RDEPEND}
@@ -32,20 +31,12 @@ src_prepare() {
-e "/README_EN.TXT/d" \
-e "/README_RU.TXT/d" \
CMakeLists.txt || die "sed failed"
- # how do I hate boost? Let me count the ways...
- local boost_ver=$(best_version "<dev-libs/boost-1.50")
+ epatch "${FILESDIR}"/${P}-boost150.patch
- boost_ver=${boost_ver/*boost-/}
- boost_ver=${boost_ver%.*}
- boost_ver=${boost_ver/./_}
-
- einfo "Using boost version ${boost_ver}"
- append-cxxflags \
- -I/usr/include/boost-${boost_ver}
- append-ldflags \
- -L/usr/$(get_libdir)/boost-${boost_ver}
- export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
- export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
+ append-cxxflags -I$(boost-utils_get_includedir)
+ append-ldflags -L$(boost-utils_get_libdir)
+ export BOOST_INCLUDEDIR=$(boost-utils_get_includedir)
+ export BOOST_LIBRARYDIR=-L$(boost-utils_get_libdir)
}
src_configure() {