summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-02 20:07:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-02 20:07:27 +0000
commit9da62e5d3978996048a9b360b3a4761d948b16e6 (patch)
treec35a926270b41b2876ffa7365964a0cb784f2c68 /games-action
parentswitched to newinitd (diff)
downloadgentoo-2-9da62e5d3978996048a9b360b3a4761d948b16e6.tar.gz
gentoo-2-9da62e5d3978996048a9b360b3a4761d948b16e6.tar.bz2
gentoo-2-9da62e5d3978996048a9b360b3a4761d948b16e6.zip
tidy
(Portage version: 2.0.53)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/parsec/parsec-0197.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/games-action/parsec/parsec-0197.ebuild b/games-action/parsec/parsec-0197.ebuild
index f71f88fab388..03e759bcd6f1 100644
--- a/games-action/parsec/parsec-0197.ebuild
+++ b/games-action/parsec/parsec-0197.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/parsec/parsec-0197.ebuild,v 1.7 2006/01/02 18:52:14 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/parsec/parsec-0197.ebuild,v 1.8 2006/01/02 20:07:27 mr_bones_ Exp $
-inherit eutils games
+inherit games
DESCRIPTION="Parsec - there is no safe distance"
HOMEPAGE="http://openparsec.sourceforge.net/"
@@ -29,9 +29,13 @@ S=${WORKDIR}/${PN}
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN}
- dodir ${dir}
- cp -r * ${D}/${dir}/
- dogamesbin ${FILESDIR}/parsec
- dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/parsec
+
+ dogamesbin "${FILESDIR}/parsec" || die "dogamesbin failed"
+ insinto "${dir}"
+ doins -r * || die "doins failed"
+ sed -i \
+ -e "s:GENTOO_DIR:${dir}:" \
+ "${D}${GAMES_BINDIR}/parsec" \
+ || die "sed failed"
prepgamesdirs
}