summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-11-22 16:16:56 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-11-22 16:16:56 +0000
commit830d9b0e98ec17bec2013d2254484500e3f45be4 (patch)
treee87114cf9a4b8f85b865de84e8716e4d14ff51ae /games-action
parentVersion bump. Fixes bugs: #108371 #109819 #111546 #102006 #103332 #103717 #10... (diff)
downloadgentoo-2-830d9b0e98ec17bec2013d2254484500e3f45be4.tar.gz
gentoo-2-830d9b0e98ec17bec2013d2254484500e3f45be4.tar.bz2
gentoo-2-830d9b0e98ec17bec2013d2254484500e3f45be4.zip
Changed 2->1 and 1->0. Changed rune.bin->rune-bin. Closing bug #113234.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/rune/ChangeLog5
-rw-r--r--games-action/rune/rune-1.07-r1.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/games-action/rune/ChangeLog b/games-action/rune/ChangeLog
index b02d303d8e59..cf52ba7ccb08 100644
--- a/games-action/rune/ChangeLog
+++ b/games-action/rune/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/rune
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rune/ChangeLog,v 1.3 2005/11/22 01:46:02 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rune/ChangeLog,v 1.4 2005/11/22 16:16:56 wolf31o2 Exp $
+
+ 22 Nov 2005; Chris Gianelloni <wolf31o2@gentoo.org> rune-1.07-r1.ebuild:
+ Changed 2->1 and 1->0. Changed rune.bin->rune-bin. Closing bug #113234.
*rune-1.07-r1 (22 Nov 2005)
diff --git a/games-action/rune/rune-1.07-r1.ebuild b/games-action/rune/rune-1.07-r1.ebuild
index 63d3a3ef7da6..31ef20318130 100644
--- a/games-action/rune/rune-1.07-r1.ebuild
+++ b/games-action/rune/rune-1.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rune/rune-1.07-r1.ebuild,v 1.1 2005/11/22 01:46:02 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rune/rune-1.07-r1.ebuild,v 1.2 2005/11/22 16:16:56 wolf31o2 Exp $
inherit eutils games
@@ -30,21 +30,21 @@ dir=${GAMES_PREFIX_OPT}/${PN}
Ddir=${D}/${dir}
pkg_setup() {
-export CDROM_SET_NAMES=("Linux Rune CD" "Windows Rune CD")
- cdrom_get_cds System/rune.bin:System/Rune.exe
+ export CDROM_SET_NAMES=("Linux Rune CD" "Windows Rune CD")
+ cdrom_get_cds System/rune-bin:System/Rune.exe
games_pkg_setup
}
src_unpack() {
dodir "${dir}"
- if [[ ${CDROM_SET} -eq 1 ]]
+ if [[ ${CDROM_SET} -eq 0 ]]
then
# unpack the data files
tar xzf "${CDROM_ROOT}"/data.tar.gz || die "Could not unpack data.tar.gz"
- elif [[ ${CDROM_SET} -eq 2 ]]
+ elif [[ ${CDROM_SET} -eq 1 ]]
then
# unpack the runelinuxfiles.tar.gz
- unpack ${A} || die "Could not unpack runelinuxfiles.tar.gz"
+ unpack ${A} || die "Could not unpack rune-all-0.1.tar.bz2"
fi
}
@@ -54,7 +54,7 @@ src_install() {
einfo "Copying files... this may take a while..."
case ${CDROM_SET} in
- 1)
+ 0)
for x in Help Maps Meshes Sounds System Textures Web
do
doins -r $x || die "copying $x"
@@ -74,7 +74,7 @@ src_install() {
dodoc "${CDROM_ROOT}"/{README,CREDITS} || die "Could not dodoc README.linux"
newicon "${CDROM_ROOT}"/icon.xpm rune.xpm || die "Could not copy pixmap"
;;
- 2)
+ 1)
# copying Maps Sounds and Web
for x in Maps Sounds Web
do