summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-04 09:11:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-04 09:11:53 +0000
commit12eb4575a06b5948f82fedfe8741334cab6666a0 (patch)
treeb84a6a649270e163743f4262cdd62949e405c897 /games-action
parentVersion bump. Closes #49783. Corrected HOMEPAGE in all ebuilds. (Manifest rec... (diff)
downloadgentoo-2-12eb4575a06b5948f82fedfe8741334cab6666a0.tar.gz
gentoo-2-12eb4575a06b5948f82fedfe8741334cab6666a0.tar.bz2
gentoo-2-12eb4575a06b5948f82fedfe8741334cab6666a0.zip
touch
Diffstat (limited to 'games-action')
-rw-r--r--games-action/atanks/atanks-1.1.0.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/games-action/atanks/atanks-1.1.0.ebuild b/games-action/atanks/atanks-1.1.0.ebuild
index 82b08bf40e54..36e32ce41692 100644
--- a/games-action/atanks/atanks-1.1.0.ebuild
+++ b/games-action/atanks/atanks-1.1.0.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.3 2004/06/24 21:51:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.4 2004/09/04 09:11:53 mr_bones_ Exp $
inherit games
DATA_DIR="${GAMES_DATADIR}/${PN}"
-S="${WORKDIR}/${PN}"
DESCRIPTION="Worms and Scorched Earth-like game"
HOMEPAGE="http://atanks.sourceforge.net/"
SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
IUSE=""
RDEPEND="virtual/x11
@@ -20,6 +20,8 @@ RDEPEND="virtual/x11
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
+S="${WORKDIR}/${PN}"
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -32,14 +34,15 @@ src_unpack() {
src_install() {
dogamesbin atanks || die "dogamesbin failed"
dodir "${DATA_DIR}"
- cp {credits,gloat,instr,revenge}.txt *dat "${D}${DATA_DIR}" || \
- die "cp failed"
- dodoc BUGS Changelog Help.txt tanks.txt README TODO || die "dodoc failed"
+ cp {credits,gloat,instr,revenge}.txt *dat "${D}${DATA_DIR}" \
+ || die "cp failed"
+ dodoc BUGS Changelog Help.txt tanks.txt README TODO
prepgamesdirs
}
pkg_postinst() {
+ games_pkg_postinst
+ echo
einfo "NOTE: If you had atanks version 0.9.8b or less installed"
einfo "remove ~/.atanks-config to take advantage of new features."
- games_pkg_postinst
}