summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-09 18:42:33 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-09 18:42:33 +0000
commit5e9a0efb1ab1398198b1f320edb2cca89ed7e792 (patch)
treeb95145707216e5fea17838a21815f8cdbd2eb228 /games-action/towbowl-tactics
parent+move games-action/twobowl-tactics games-action/towbowl-tactics (diff)
downloadgentoo-2-5e9a0efb1ab1398198b1f320edb2cca89ed7e792.tar.gz
gentoo-2-5e9a0efb1ab1398198b1f320edb2cca89ed7e792.tar.bz2
gentoo-2-5e9a0efb1ab1398198b1f320edb2cca89ed7e792.zip
moved twobowl-tactics to towbowl-tactics, Doh!
Diffstat (limited to 'games-action/towbowl-tactics')
-rw-r--r--games-action/towbowl-tactics/ChangeLog13
-rw-r--r--games-action/towbowl-tactics/Manifest4
-rw-r--r--games-action/towbowl-tactics/files/digest-towbowl-tactics-0.51
-rw-r--r--games-action/towbowl-tactics/metadata.xml5
-rw-r--r--games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild59
5 files changed, 82 insertions, 0 deletions
diff --git a/games-action/towbowl-tactics/ChangeLog b/games-action/towbowl-tactics/ChangeLog
new file mode 100644
index 000000000000..dfc761cdbf7e
--- /dev/null
+++ b/games-action/towbowl-tactics/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for games-action/towbowl-tactics
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/towbowl-tactics/ChangeLog,v 1.1 2004/03/09 18:42:33 mr_bones_ Exp $
+
+ 09 Mar 2004; David Holm <dholm@gentoo.org> twobowl-tactics-0.5.ebuild:
+ Added to ~ppc.
+
+*twobowl-tactics-0.5 (09 Mar 2004)
+
+ 09 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
+ twobowl-tactics-0.5.ebuild:
+ initial commit; ebuild submitted by eGore via bug #43871 (modified)
+
diff --git a/games-action/towbowl-tactics/Manifest b/games-action/towbowl-tactics/Manifest
new file mode 100644
index 000000000000..2ee989d5296d
--- /dev/null
+++ b/games-action/towbowl-tactics/Manifest
@@ -0,0 +1,4 @@
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 9910aa22331d10d05df7f39eabf91d41 ChangeLog 534
+MD5 733a5e5822227f635f3fbdbb882d7382 towbowl-tactics-0.5.ebuild 1594
+MD5 cfa388127da9669f2fdc08df6cc8f8db files/digest-towbowl-tactics-0.5 61
diff --git a/games-action/towbowl-tactics/files/digest-towbowl-tactics-0.5 b/games-action/towbowl-tactics/files/digest-towbowl-tactics-0.5
new file mode 100644
index 000000000000..6386e0ff4842
--- /dev/null
+++ b/games-action/towbowl-tactics/files/digest-towbowl-tactics-0.5
@@ -0,0 +1 @@
+MD5 049b3901cf166f740902a9f89a771e40 tbt.0.5.src.zip 5321239
diff --git a/games-action/towbowl-tactics/metadata.xml b/games-action/towbowl-tactics/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/towbowl-tactics/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild b/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
new file mode 100644
index 000000000000..47abfa074573
--- /dev/null
+++ b/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild,v 1.1 2004/03/09 18:42:33 mr_bones_ Exp $
+
+inherit eutils games
+
+S="${WORKDIR}/tbt/src"
+DESCRIPTION="Tow Bowl Tactics is a game based on Games Workshop's Blood Bowl"
+HOMEPAGE="http://www.towbowltactics.com/index_en.html"
+SRC_URI="http://www.towbowltactics.com/download/tbt.${PV}.src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+RDEPEND="virtual/glibc
+ >=dev-libs/libxml2-2.6.6
+ >=media-libs/smpeg-0.4.4
+ >=media-libs/sdl-net-1.2.5
+ >=media-libs/sdl-image-1.2.3
+ >=media-libs/sdl-mixer-1.2.5"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ local f
+
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s/<language>0/<language>1/g" ../config.xml \
+ || die "sed config.xml failed"
+ sed -i \
+ -e "/^CFLAGS/ s:-O2 -g -fno-strength-reduce -Wall -W:${CFLAGS}:" \
+ -e "/^TBTHOME/ s:/.*:${GAMES_DATADIR}/tbt:" Makefile \
+ || die "sed Makefile failed"
+ sed -i \
+ -e "/tbt.ico/ s:\"\./:TBTHOME \"/:" Main.cpp \
+ || die "sed Main.cpp failed"
+ sed -i \
+ -e "s:TBTHOME \"/config.xml:\"${GAMES_SYSCONFDIR}/tbt/config.xml:g" \
+ global.h || die "sed global,h failed"
+
+ for f in `find ${S} -type f`
+ do
+ edos2unix ${f}
+ done
+}
+
+src_install() {
+ dogamesbin tbt || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/tbt"
+ cp -r ../data ../tbt.ico "${D}${GAMES_DATADIR}/tbt" || die "cp failed"
+ insinto "${GAMES_SYSCONFDIR}/tbt"
+ doins ../config.xml || die "doins failed"
+ prepgamesdirs
+}