summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-05-12 21:50:56 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-05-12 21:50:56 +0000
commit04d13d68000e02c8107cb9fb54b56d7969cc4c37 (patch)
tree3a1746ab515cc0a9bdf445a719edd67b1e569fca /games-action/spacetripper-demo/spacetripper-demo-1.ebuild
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-04d13d68000e02c8107cb9fb54b56d7969cc4c37.tar.gz
gentoo-2-04d13d68000e02c8107cb9fb54b56d7969cc4c37.tar.bz2
gentoo-2-04d13d68000e02c8107cb9fb54b56d7969cc4c37.zip
Moved from spacetripperdemo to spacetripper-demo.
Diffstat (limited to 'games-action/spacetripper-demo/spacetripper-demo-1.ebuild')
-rw-r--r--games-action/spacetripper-demo/spacetripper-demo-1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-action/spacetripper-demo/spacetripper-demo-1.ebuild b/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
new file mode 100644
index 000000000000..62d8c2f0084d
--- /dev/null
+++ b/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/spacetripper-demo/spacetripper-demo-1.ebuild,v 1.1 2004/05/12 21:50:56 wolf31o2 Exp $
+
+inherit games eutils
+
+MY_P="spacetripperdemo"
+DESCRIPTION="hardcore arcade shoot-em-up"
+HOMEPAGE="http://www.pompom.org.uk/"
+SRC_URI="http://www.btinternet.com/%7Ebongpig/${MY_P}.sh"
+
+LICENSE="POMPOM"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ check_license
+ unpack_makeself
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir} ${GAMES_BINDIR}
+
+ cp -r preview run styles ${D}/${dir}/
+
+ exeinto ${dir}
+ doexe bin/x86/*
+ dosed "s:XYZZY:${dir}:" ${dir}/${PN}
+ dosym ${dir}/spacetripperdemo ${GAMES_BINDIR}/${PN}
+
+ insinto ${dir}
+ doins README license.txt icon.xpm
+
+ prepgamesdirs
+}