summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-20 07:39:08 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-20 07:39:08 +0000
commit87b33cbe522f3c128d912608d255254043165f44 (patch)
tree9635d164ffdcfe3a71060e075f0c6155c5609fc3 /games-action/phobiaii
parentBump to new patch release, remove some of our workarounds (diff)
downloadgentoo-2-87b33cbe522f3c128d912608d255254043165f44.tar.gz
gentoo-2-87b33cbe522f3c128d912608d255254043165f44.tar.bz2
gentoo-2-87b33cbe522f3c128d912608d255254043165f44.zip
Use games_make_wrapper
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'games-action/phobiaii')
-rw-r--r--games-action/phobiaii/ChangeLog6
-rw-r--r--games-action/phobiaii/files/digest-phobiaii-1.12
-rw-r--r--games-action/phobiaii/phobiaii-1.1.ebuild19
3 files changed, 15 insertions, 12 deletions
diff --git a/games-action/phobiaii/ChangeLog b/games-action/phobiaii/ChangeLog
index 6939b23e20b3..2d855856838b 100644
--- a/games-action/phobiaii/ChangeLog
+++ b/games-action/phobiaii/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/phobiaii
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/phobiaii/ChangeLog,v 1.8 2006/09/15 19:52:50 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/phobiaii/ChangeLog,v 1.9 2006/10/20 07:39:07 nyhm Exp $
+
+ 20 Oct 2006; Tristan Heaven <nyhm@gentoo.org> -files/phobiaII,
+ phobiaii-1.1.ebuild:
+ Use games_make_wrapper
15 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org> phobiaii-1.1.ebuild:
I forgot the s in my sed. Bad me.
diff --git a/games-action/phobiaii/files/digest-phobiaii-1.1 b/games-action/phobiaii/files/digest-phobiaii-1.1
index ce731e005268..ae128e6292fc 100644
--- a/games-action/phobiaii/files/digest-phobiaii-1.1
+++ b/games-action/phobiaii/files/digest-phobiaii-1.1
@@ -1 +1,3 @@
MD5 e5d3deac8f4c03a3fd3855c5a2449535 linuxphobia-1.1-i386.tar.bz2 7709686
+RMD160 097a3894987038fdc2a374dd065716119821da03 linuxphobia-1.1-i386.tar.bz2 7709686
+SHA256 f70b66a919d04e828d0c2e3e84f7e90659dd6891cbadfe66413298c5db7c87af linuxphobia-1.1-i386.tar.bz2 7709686
diff --git a/games-action/phobiaii/phobiaii-1.1.ebuild b/games-action/phobiaii/phobiaii-1.1.ebuild
index b477a2498d9a..6bed76e9c9d1 100644
--- a/games-action/phobiaii/phobiaii-1.1.ebuild
+++ b/games-action/phobiaii/phobiaii-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/phobiaii/phobiaii-1.1.ebuild,v 1.11 2006/09/15 19:52:50 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/phobiaii/phobiaii-1.1.ebuild,v 1.12 2006/10/20 07:39:07 nyhm Exp $
inherit games
@@ -19,22 +19,19 @@ DEPEND=""
RDEPEND="media-libs/sdl-mixer
media-libs/libsdl
x86? ( sys-libs/lib-compat )
- amd64? ( app-emulation/emul-linux-x86-compat )
- virtual/libc"
+ amd64? ( app-emulation/emul-linux-x86-compat )"
S=${WORKDIR}/${MY_P}
src_install() {
- dodoc README
- rm setup-link.sh README
+ local dir=${GAMES_PREFIX_OPT}/${PN}
- dodir "${GAMES_PREFIX_OPT}"/${PN}
- mv * "${D}/${GAMES_PREFIX_OPT}"/${PN}/
+ games_make_wrapper ${PN/ii/II} ./linuxphobia "${dir}"
- dosed "s:GAMES_PREFIX_OPT:${GAMES_PREFIX_OPT}:" \
- ${GAMES_BINDIR}/phobiaII || die "sed"
+ insinto "${dir}"
+ doins -r * || die "doins failed"
-
- dogamesbin "${FILESDIR}"/phobiaII || die "dogamesbin failed"
+ rm -rf "${D}/${dir}"/{*.desktop,*.sh,*.ico,/pics/.xvpics}
+ fperms 750 "${dir}"/linuxphobia
prepgamesdirs
}