summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-17 03:06:02 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-17 03:06:02 +0000
commit388c51b20e739851122aec6e0256d7f2f2e3677b (patch)
tree0b11b3b0c9b793fb574117036a893077dca7982e /games-action/luola
parentvanilla-3.7.8 + genpatches-3.7-10 + grsecurity-2.9.1-3.7.8-201302161158 (diff)
downloadgentoo-2-388c51b20e739851122aec6e0256d7f2f2e3677b.tar.gz
gentoo-2-388c51b20e739851122aec6e0256d7f2f2e3677b.tar.bz2
gentoo-2-388c51b20e739851122aec6e0256d7f2f2e3677b.zip
version bump
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action/luola')
-rw-r--r--games-action/luola/ChangeLog10
-rw-r--r--games-action/luola/files/luola-1.3.2-underlink.patch11
-rw-r--r--games-action/luola/luola-1.3.2.ebuild59
3 files changed, 78 insertions, 2 deletions
diff --git a/games-action/luola/ChangeLog b/games-action/luola/ChangeLog
index 4ef0af052387..12990a90fd21 100644
--- a/games-action/luola/ChangeLog
+++ b/games-action/luola/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/luola
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/luola/ChangeLog,v 1.11 2011/06/17 10:25:17 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/luola/ChangeLog,v 1.12 2013/02/17 03:06:02 hasufell Exp $
+
+*luola-1.3.2 (17 Feb 2013)
+
+ 17 Feb 2013; Julian Ospald <hasufell@gentoo.org> +luola-1.3.2.ebuild,
+ +files/luola-1.3.2-underlink.patch:
+ version bump
17 Jun 2011; Tupone Alfredo <tupone@gentoo.org> luola-1.3.0-r1.ebuild,
+files/luola-1.3.0-underlink.patch:
diff --git a/games-action/luola/files/luola-1.3.2-underlink.patch b/games-action/luola/files/luola-1.3.2-underlink.patch
new file mode 100644
index 000000000000..5bf998177be7
--- /dev/null
+++ b/games-action/luola/files/luola-1.3.2-underlink.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.am.old 2011-06-17 08:41:40.882481147 +0200
++++ src/Makefile.am 2011-06-17 08:41:58.497602372 +0200
+@@ -2,7 +2,7 @@
+
+ bin_PROGRAMS = luola
+
+-luola_LDADD = @SDL_LIBS@
++luola_LDADD = @SDL_LIBS@ -lm
+
+ luola_SOURCES = \
+ defines.h \
diff --git a/games-action/luola/luola-1.3.2.ebuild b/games-action/luola/luola-1.3.2.ebuild
new file mode 100644
index 000000000000..1ab09e43de00
--- /dev/null
+++ b/games-action/luola/luola-1.3.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/luola/luola-1.3.2.ebuild,v 1.1 2013/02/17 03:06:02 hasufell Exp $
+
+EAPI=5
+inherit eutils autotools gnome2-utils games
+
+DESCRIPTION="A 2D multiplayer arcade game resembling V-Wing"
+HOMEPAGE="http://luolamies.org/software/luola/"
+SRC_URI="http://luolamies.org/software/luola/${P}.tar.gz
+ http://www.luolamies.org/software/luola/stdlevels-6.0.tar.gz
+ http://www.luolamies.org/software/luola/nostalgia-1.2.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[X,audio,joystick,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlink.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf --enable-sound
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ insinto "${GAMES_DATADIR}"/${PN}/levels
+ doins "${WORKDIR}"/*.{lev,png}
+ dodoc AUTHORS ChangeLog DATAFILE FAQ LEVELFILE README TODO \
+ RELEASENOTES.txt ../README.Nostalgia
+ newdoc ../README README.stdlevels
+ doicon -s 64 luola.png
+ make_desktop_entry luola Luola
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}