summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-04-13 19:43:16 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-04-13 19:43:16 +0000
commitf6982bdd9daaf6d2a4e68d9b4599b3f15957509e (patch)
treea2afb1f532fe0b108034c2593d8b10f1edecf700 /games-action/d2x
parentMoved games_pkg_setup to the beginning of pkg_setup. (diff)
downloadgentoo-2-f6982bdd9daaf6d2a4e68d9b4599b3f15957509e.tar.gz
gentoo-2-f6982bdd9daaf6d2a4e68d9b4599b3f15957509e.tar.bz2
gentoo-2-f6982bdd9daaf6d2a4e68d9b4599b3f15957509e.zip
Removing old ebuild.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'games-action/d2x')
-rw-r--r--games-action/d2x/ChangeLog5
-rw-r--r--games-action/d2x/d2x-0.2.5-r1.ebuild99
-rw-r--r--games-action/d2x/files/digest-d2x-0.2.5-r12
3 files changed, 4 insertions, 102 deletions
diff --git a/games-action/d2x/ChangeLog b/games-action/d2x/ChangeLog
index 5cfbc35ee962..2902cf11f24b 100644
--- a/games-action/d2x/ChangeLog
+++ b/games-action/d2x/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/d2x
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.14 2006/01/03 20:53:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.15 2006/04/13 19:43:16 wolf31o2 Exp $
+
+ 13 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org> -d2x-0.2.5-r1.ebuild:
+ Removing old ebuild.
03 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org> d2x-0.2.5-r2.ebuild:
fix up LICENSE (bug #117344)
diff --git a/games-action/d2x/d2x-0.2.5-r1.ebuild b/games-action/d2x/d2x-0.2.5-r1.ebuild
deleted file mode 100644
index fd805fbf1be7..000000000000
--- a/games-action/d2x/d2x-0.2.5-r1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.8 2005/07/07 13:39:28 wolf31o2 Exp $
-
-inherit flag-o-matic eutils games
-
-DATAFILE="d2shar10"
-DESCRIPTION="Descent 2"
-HOMEPAGE="http://icculus.org/d2x/"
-SRC_URI="http://icculus.org/d2x/src/${P}.tar.gz
- !cdinstall? ( http://icculus.org/d2x/data/${DATAFILE}.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="ppc x86"
-IUSE="cdinstall debug opengl ggi svga"
-
-RDEPEND="media-libs/libsdl
- media-libs/sdl-image
- cdinstall? ( app-arch/unarj )
- opengl? ( virtual/opengl )
- ggi? ( media-libs/libggi )
- svga? ( media-libs/svgalib )"
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )"
-
-pkg_setup() {
- games_pkg_setup
-
- if use cdinstall ; then
- if [[ ! -e ${DISTDIR}/descent2.sow ]] ; then
- cdrom_get_cds d2data
- if [ -e ${CDROM_ROOT}/d2data/descent2.sow ] ; then
- export CDROM_ROOT=${CDROM_ROOT}/d2data
- einfo "Found the original Descent2 CD"
- einfo "Copying descent2.sow to ${DISTDIR}"
- cp ${CDROM_ROOT}/descent2.sow ${DISTDIR}/descent2.sow
- else
- die "You need the original Descent2 CD"
- fi
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- if use cdinstall ; then
- cd ${WORKDIR}
- mkdir SOW
- cd SOW
- unarj e ${DISTDIR}/descent2.sow
- fi
- rm *.{exe,bat}
- cd ${S}
- epatch ${FILESDIR}/${PV}-shellscripts.patch
-}
-
-src_compile() {
- # --disable-network --enable-console
- local myconf="$(use_enable x86 assembler)"
- use debug \
- && myconf="${myconf} --enable-debug --disable-release" \
- || myconf="${myconf} --disable-debug --enable-release"
- # we do this because each of the optional guys define the same functions
- # in gr, thus when they go to link they cause redefine errors ...
- # we build each by it self, save the binary file, clean up, and start over
- mkdir my-bins
- for ren in sdl $(useq opengl && echo opengl) \
- $(useq svga && echo svga) $(useq ggi && echo ggi)
- do
- [ "${ren}" == "sdl" ] \
- && renconf="" \
- || renconf="--with-${ren}"
- [ "${ren}" == "svga" ] \
- && defflags="-DSVGALIB_INPUT" \
- || defflags=""
- make distclean
- egamesconf \
- ${myconf} \
- ${renconf} \
- --datadir=${GAMES_DATADIR_BASE} \
- || die "conf ${ren}"
- emake CXXFLAGS="${CXXFLAGS} ${defflags}" || die "build ${ren}"
- mv d2x* my-bins/
- done
-}
-
-src_install() {
- make install DESTDIR=${D} || die
- dogamesbin my-bins/*
- dodir ${GAMES_DATADIR}/${PN}
- if use cdinstall ; then
- cp -r ${WORKDIR}/SOW/* ${D}/${GAMES_DATADIR}/${PN}/
- else
- cp -r ${WORKDIR}/${DATAFILE}/* ${D}/${GAMES_DATADIR}/${PN}/
- fi
- dodoc AUTHORS ChangeLog NEWS README* TODO readme.txt
- prepgamesdirs
-}
diff --git a/games-action/d2x/files/digest-d2x-0.2.5-r1 b/games-action/d2x/files/digest-d2x-0.2.5-r1
deleted file mode 100644
index 3bae26d927d8..000000000000
--- a/games-action/d2x/files/digest-d2x-0.2.5-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 79474db1ff4f0ae1fb76d691701cc560 d2x-0.2.5.tar.gz 2015249
-MD5 1b952cc4a4419e24d230589027d73490 d2shar10.tar.gz 4311406