summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-24 22:31:42 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-24 22:31:42 +0000
commit73a1b065d600421a98c208e16c9ba8ebf925e455 (patch)
treeebf400850fc1554cb2b558cc9ac2d2e664b6847f /games-action/d2x
parentMoved cdrom_get_cds to src_unpack since binary packages don't require the ori... (diff)
downloadgentoo-2-73a1b065d600421a98c208e16c9ba8ebf925e455.tar.gz
gentoo-2-73a1b065d600421a98c208e16c9ba8ebf925e455.tar.bz2
gentoo-2-73a1b065d600421a98c208e16c9ba8ebf925e455.zip
Moved cdrom_get_cds to src_unpack since binary packages don't require the original media to install as well as some general cleanup.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'games-action/d2x')
-rw-r--r--games-action/d2x/ChangeLog6
-rw-r--r--games-action/d2x/d2x-0.2.5-r2.ebuild35
2 files changed, 19 insertions, 22 deletions
diff --git a/games-action/d2x/ChangeLog b/games-action/d2x/ChangeLog
index 2902cf11f24b..fde8aa8bea60 100644
--- a/games-action/d2x/ChangeLog
+++ b/games-action/d2x/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/d2x
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.15 2006/04/13 19:43:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.16 2006/10/24 22:31:42 wolf31o2 Exp $
+
+ 24 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org> d2x-0.2.5-r2.ebuild:
+ Moved cdrom_get_cds to src_unpack since binary packages don't require the
+ original media to install as well as some general cleanup.
13 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org> -d2x-0.2.5-r1.ebuild:
Removing old ebuild.
diff --git a/games-action/d2x/d2x-0.2.5-r2.ebuild b/games-action/d2x/d2x-0.2.5-r2.ebuild
index 7e642b4d5481..72b02560c14f 100644
--- a/games-action/d2x/d2x-0.2.5-r2.ebuild
+++ b/games-action/d2x/d2x-0.2.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r2.ebuild,v 1.4 2006/01/03 20:53:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r2.ebuild,v 1.5 2006/10/24 22:31:42 wolf31o2 Exp $
inherit flag-o-matic eutils games
@@ -24,36 +24,29 @@ RDEPEND="media-libs/libsdl
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
-pkg_setup() {
- games_pkg_setup
-
+src_unpack() {
+ unpack ${A}
if use cdinstall ; then
- if [[ ! -e ${DISTDIR}/descent2.sow ]] ; then
+ if [[ ! -e "${DISTDIR}"/descent2.sow ]] ; then
cdrom_get_cds d2data
if [ -e ${CDROM_ROOT}/d2data/descent2.sow ] ; then
export CDROM_ROOT=${CDROM_ROOT}/d2data
einfo "Found the original Descent2 CD"
einfo "Copying descent2.sow to ${DISTDIR}"
- cp ${CDROM_ROOT}/descent2.sow ${DISTDIR}/descent2.sow
+ cp ${CDROM_ROOT}/descent2.sow "${DISTDIR}"/descent2.sow
else
die "You need the original Descent2 CD"
fi
fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- if use cdinstall ; then
- cd ${WORKDIR}
+ cd "${WORKDIR}"
mkdir SOW
cd SOW
- unarj e ${DISTDIR}/descent2.sow
+ unarj e "${DISTDIR}"/descent2.sow
fi
rm *.{exe,bat}
- cd ${S}
- epatch ${FILESDIR}/${PV}-shellscripts.patch
- epatch ${FILESDIR}/${P}-dofpcalcs-macro.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-shellscripts.patch
+ epatch "${FILESDIR}"/${P}-dofpcalcs-macro.patch
}
src_compile() {
@@ -87,13 +80,13 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die
+ make install DESTDIR="${D}" || die
dogamesbin my-bins/*
- dodir ${GAMES_DATADIR}/${PN}
+ dodir "${GAMES_DATADIR}"/${PN}
if use cdinstall ; then
- cp -r ${WORKDIR}/SOW/* ${D}/${GAMES_DATADIR}/${PN}/
+ cp -r "${WORKDIR}"/SOW/* "${D}/${GAMES_DATADIR}"/${PN}/
else
- cp -r ${WORKDIR}/${DATAFILE}/* ${D}/${GAMES_DATADIR}/${PN}/
+ cp -r "${WORKDIR}"/${DATAFILE}/* "${D}/${GAMES_DATADIR}"/${PN}/
fi
dodoc AUTHORS ChangeLog NEWS README* TODO readme.txt
prepgamesdirs