summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-30 04:45:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-30 04:45:22 +0000
commit820f9002679250c970101f311ee1d71a87c65d1a (patch)
tree455aa5e68a4383ac8ba86057de373de4c4f2fbfa /games-action/chromium/chromium-0.9.12-r5.ebuild
parentStable on mips, bug #75143 (Manifest recommit) (diff)
downloadgentoo-2-820f9002679250c970101f311ee1d71a87c65d1a.tar.gz
gentoo-2-820f9002679250c970101f311ee1d71a87c65d1a.tar.bz2
gentoo-2-820f9002679250c970101f311ee1d71a87c65d1a.zip
tidy ebuild and add patch for gcc-34 to the gcc-3 patch (bug #76094)
Diffstat (limited to 'games-action/chromium/chromium-0.9.12-r5.ebuild')
-rw-r--r--games-action/chromium/chromium-0.9.12-r5.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/games-action/chromium/chromium-0.9.12-r5.ebuild b/games-action/chromium/chromium-0.9.12-r5.ebuild
index 171c74329988..d1c4c1f96981 100644
--- a/games-action/chromium/chromium-0.9.12-r5.ebuild
+++ b/games-action/chromium/chromium-0.9.12-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r5.ebuild,v 1.8 2004/06/30 02:32:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r5.ebuild,v 1.9 2004/12/30 04:45:22 mr_bones_ Exp $
inherit flag-o-matic eutils games
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="x86 ppc amd64 ~sparc"
IUSE="qt sdl oggvorbis"
-RDEPEND="virtual/libc
+DEPEND="virtual/libc
|| (
sdl? ( media-libs/libsdl
media-libs/smpeg )
@@ -24,17 +24,15 @@ RDEPEND="virtual/libc
qt? ( x11-libs/qt )
media-libs/openal
virtual/x11"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
S="${WORKDIR}/Chromium-0.9"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-gcc3-gentoo.patch
- epatch ${FILESDIR}/${PV}-proper-options.patch
- has_version '=x11-libs/qt-3*' && epatch ${FILESDIR}/${PV}-qt3.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-gcc3-gentoo.patch"
+ epatch "${FILESDIR}/${PV}-proper-options.patch"
+ has_version '=x11-libs/qt-3*' && epatch "${FILESDIR}/${PV}-qt3.patch"
append-flags -DPKGDATADIR="'\"${GAMES_DATADIR}/${PN}\"'"
append-flags -DPKGBINDIR="'\"${GAMES_BINDIR}\"'"
sed -i \
@@ -46,6 +44,7 @@ src_unpack() {
sed -i \
-e "s:-O2:${CFLAGS}:" support/glpng/src/Makefile \
|| die "sed support/glpng/src/Makefile failed"
+ find "${S}" -type d -name CVS -exec rm -rf '{}' \; >& /dev/null
}
src_compile() {
@@ -72,13 +71,8 @@ src_compile() {
}
src_install() {
- exeinto "${GAMES_BINDIR}"
- doexe bin/chromium* || die "doexe failed"
-
+ dogamesbin bin/chromium* || die "dogamesbin failed"
dodir "${GAMES_DATADIR}/${PN}"
cp -r data "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
-
- find "${D}" -name CVS -exec rm -rf '{}' \; >& /dev/null
-
prepgamesdirs
}