summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-14 05:56:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-14 05:56:12 +0000
commit998707c562d96864768f8a9c89eb8e48204f239d (patch)
tree9909ebde947b8124b75fc412e2cffaec9da6d460 /games-action/bzflag
parentVersion bump. (diff)
downloadgentoo-2-998707c562d96864768f8a9c89eb8e48204f239d.tar.gz
gentoo-2-998707c562d96864768f8a9c89eb8e48204f239d.tar.bz2
gentoo-2-998707c562d96864768f8a9c89eb8e48204f239d.zip
add desktop entry support for bug #85155
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-action/bzflag')
-rw-r--r--games-action/bzflag/ChangeLog6
-rw-r--r--games-action/bzflag/bzflag-2.0.0.20050117.ebuild18
2 files changed, 18 insertions, 6 deletions
diff --git a/games-action/bzflag/ChangeLog b/games-action/bzflag/ChangeLog
index f131e4d8f861..208e5f500ae2 100644
--- a/games-action/bzflag/ChangeLog
+++ b/games-action/bzflag/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/bzflag
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.16 2005/01/27 13:16:38 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.17 2005/03/14 05:56:12 mr_bones_ Exp $
+
+ 14 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ bzflag-2.0.0.20050117.ebuild:
+ add desktop entry support for bug #85155
27 Jan 2005; Chris Gianelloni <wolf31o2@gentoo.org>
bzflag-1.10.8.20041007.ebuild, bzflag-2.0.0.20050117.ebuild:
diff --git a/games-action/bzflag/bzflag-2.0.0.20050117.ebuild b/games-action/bzflag/bzflag-2.0.0.20050117.ebuild
index f8769434638f..f536349b8800 100644
--- a/games-action/bzflag/bzflag-2.0.0.20050117.ebuild
+++ b/games-action/bzflag/bzflag-2.0.0.20050117.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.0.20050117.ebuild,v 1.5 2005/03/13 06:17:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.0.20050117.ebuild,v 1.6 2005/03/14 05:56:12 mr_bones_ Exp $
-inherit flag-o-matic games
+inherit eutils flag-o-matic games
DESCRIPTION="OpenGL accelerated 3d tank combat simulator game"
HOMEPAGE="http://www.BZFlag.org/"
@@ -14,13 +14,17 @@ KEYWORDS="amd64 ppc x86"
IUSE="adns curl dedicated"
# kerberos"
-RDEPEND="!dedicated? ( virtual/opengl media-libs/libsdl )
- adns? ( net-libs/adns )
- curl? ( net-misc/curl )"
+RDEPEND="adns? ( net-libs/adns )
+ curl? ( net-misc/curl )
+ !dedicated? (
+ virtual/opengl
+ media-libs/libsdl )"
+
src_unpack() {
unpack ${A}
cd "${S}"
+ cp data/bzflag-48x48.png "${T}/bzflag.png"
sed -i \
-e 's:^CFLAGS=.*::' \
-e 's:^CXXFLAGS=.*::' \
@@ -51,5 +55,9 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS README.UNIX TODO README ChangeLog BUGS PORTING
+ if ! use dedicated ; then
+ doicon "${T}/bzflag.png"
+ make_desktop_entry bzflag "BZFlag"
+ fi
prepgamesdirs
}