summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-24 00:59:06 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-24 00:59:06 +0000
commitaff8ff9fa39bea8a8a2eee0cc646e0cb2ecc168c (patch)
tree97977a439ca1e47898ce0825984a3684e586c788 /games-action/bombermaze/bombermaze-0.6.6.ebuild
parentNew version: 19.1. Added 19.0 to x86. Removed obsolete version: 18.39. (diff)
downloadgentoo-2-aff8ff9fa39bea8a8a2eee0cc646e0cb2ecc168c.tar.gz
gentoo-2-aff8ff9fa39bea8a8a2eee0cc646e0cb2ecc168c.tar.bz2
gentoo-2-aff8ff9fa39bea8a8a2eee0cc646e0cb2ecc168c.zip
Fix building with newer gcc versions #93736 by Igor Galchevsky.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-action/bombermaze/bombermaze-0.6.6.ebuild')
-rw-r--r--games-action/bombermaze/bombermaze-0.6.6.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/games-action/bombermaze/bombermaze-0.6.6.ebuild b/games-action/bombermaze/bombermaze-0.6.6.ebuild
index 6430c82aea5d..9353065303e0 100644
--- a/games-action/bombermaze/bombermaze-0.6.6.ebuild
+++ b/games-action/bombermaze/bombermaze-0.6.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bombermaze/bombermaze-0.6.6.ebuild,v 1.5 2004/06/24 21:52:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bombermaze/bombermaze-0.6.6.ebuild,v 1.6 2005/05/24 00:59:06 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
DESCRIPTION="Bomberman clone for GNOME"
HOMEPAGE="http://www.freesoftware.fsf.org/bombermaze/"
@@ -10,7 +10,7 @@ SRC_URI="http://freesoftware.fsf.org/download/bombermaze/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="amd64 ppc x86"
IUSE="nls"
RDEPEND=">=media-libs/gdk-pixbuf-0.8
@@ -18,20 +18,24 @@ RDEPEND=">=media-libs/gdk-pixbuf-0.8
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc.patch
+ sed -i \
+ -e 's:destdir=:destdir=$(DESTDIR):' \
+ po/Makefile.in.in || die "sed po"
+}
+
src_compile() {
# It normally fails to locate gdk-pixbuf.h
append-flags $(gdk-pixbuf-config --cflags)
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --with-included-gettext \
- $(use_enable nls) || die "./configure failed"
-
+ econf $(use_enable nls) || die "./configure failed"
emake || die "emake failed"
}
src_install() {
- make prefix="${D}/usr" install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog NEWS TODO
}