summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-05-17 04:36:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-05-17 04:36:45 +0000
commite0de7f2a61c10a904ac2193ad856d224cef1819b (patch)
tree49a6677baad8e2e54351491470c5e86a767902da /games-action/abuse/abuse-0.8.ebuild
parentVersion bump. (diff)
downloadgentoo-2-e0de7f2a61c10a904ac2193ad856d224cef1819b.tar.gz
gentoo-2-e0de7f2a61c10a904ac2193ad856d224cef1819b.tar.bz2
gentoo-2-e0de7f2a61c10a904ac2193ad856d224cef1819b.zip
version bump
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-action/abuse/abuse-0.8.ebuild')
-rw-r--r--games-action/abuse/abuse-0.8.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-action/abuse/abuse-0.8.ebuild b/games-action/abuse/abuse-0.8.ebuild
new file mode 100644
index 000000000000..7f249f04143c
--- /dev/null
+++ b/games-action/abuse/abuse-0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/abuse-0.8.ebuild,v 1.1 2011/05/17 04:36:45 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="port of Abuse by Crack Dot Com"
+HOMEPAGE="http://abuse.zoy.org/"
+SRC_URI="http://abuse.zoy.org/raw-attachment/wiki/download/${P}.tar.gz"
+
+LICENSE="GPL-2 WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.1.6[audio,opengl,video]
+ media-libs/sdl-mixer
+ virtual/opengl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-assetdir="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ # Source-based install
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ doicon doc/${PN}.png
+ make_desktop_entry abuse Abuse
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "NOTE: If you had previous version of abuse installed"
+ elog "you may need to remove ~/.abuse for the game to work correctly."
+}