summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-07-16 14:29:39 +0000
committerMichał Górny <mgorny@gentoo.org>2015-07-16 14:29:39 +0000
commitcb7fcc88a834100d0e3e798f40cc68c395f40e85 (patch)
tree13933731262b4e859b9737633de45d70b48ee597 /eclass
parentStable on alpha, bug 551602 (diff)
downloadgentoo-2-cb7fcc88a834100d0e3e798f40cc68c395f40e85.tar.gz
gentoo-2-cb7fcc88a834100d0e3e798f40cc68c395f40e85.tar.bz2
gentoo-2-cb7fcc88a834100d0e3e798f40cc68c395f40e85.zip
Forbid also installing "examples" package, bug #555038.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog5
-rw-r--r--eclass/distutils-r1.eclass12
2 files changed, 12 insertions, 5 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index d77d6f7e9bfc..beca836fdb2d 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for eclass directory
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1711 2015/07/16 06:06:59 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1712 2015/07/16 14:29:39 mgorny Exp $
+
+ 16 Jul 2015; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Forbid also installing "examples" package, bug #555038.
16 Jul 2015; Lars Wendler <polynomial-c@gentoo.org> apache-2.eclass:
Added slot dependency for openssl. Raised minimum required EAPI version to 5.
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 575eba41444c..b3b15ba916c7 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.114 2015/07/04 15:26:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.115 2015/07/16 14:29:39 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -549,9 +549,13 @@ distutils-r1_python_install() {
esetup.py install --root="${root}" "${args[@]}"
- if [[ -d ${root}$(python_get_sitedir)/tests ]]; then
- die "Package installs 'tests' package, file collisions likely."
- fi
+ local forbidden_package_names=( examples test tests )
+ local p
+ for p in "${forbidden_package_names[@]}"; do
+ if [[ -d ${root}$(python_get_sitedir)/${p} ]]; then
+ die "Package installs '${p}' package which is forbidden and likely a bug in the build system."
+ fi
+ done
if [[ -d ${root}/usr/$(get_libdir)/pypy/share ]]; then
eqawarn "Package installs 'share' in PyPy prefix, see bug #465546."
fi