summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2005-12-04 12:01:10 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2005-12-04 12:01:10 +0000
commit4038fbc2442c68addb2639bc5d54fc07784824ff (patch)
tree14beca176d0eae83a1d10d188f385487f3842ee5 /eclass
parentMore GStreamer 0.10 Prerelease (diff)
downloadgentoo-2-4038fbc2442c68addb2639bc5d54fc07784824ff.tar.gz
gentoo-2-4038fbc2442c68addb2639bc5d54fc07784824ff.tar.bz2
gentoo-2-4038fbc2442c68addb2639bc5d54fc07784824ff.zip
GStreamer 0.10 Prerelease
Diffstat (limited to 'eclass')
-rw-r--r--eclass/gst-plugins-ugly.eclass110
1 files changed, 110 insertions, 0 deletions
diff --git a/eclass/gst-plugins-ugly.eclass b/eclass/gst-plugins-ugly.eclass
new file mode 100644
index 000000000000..ba93cf5e7377
--- /dev/null
+++ b/eclass/gst-plugins-ugly.eclass
@@ -0,0 +1,110 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-ugly.eclass,v 1.1 2005/12/04 12:01:10 zaheerm Exp $
+
+# Author : foser <foser@gentoo.org>
+
+# gst-plugins-ugly eclass
+#
+# eclass to make external gst-plugins emergable on a per-plugin basis
+# to solve the problem with gst-plugins generating far too much unneeded deps
+#
+# 3rd party applications using gstreamer now should depend on a set of plugins as
+# defined in the source, in case of spider usage obtain recommended plugins to use from
+# Gentoo developers responsible for gstreamer <gnome@gentoo.org>, the application developer
+# or the gstreamer team.
+
+inherit eutils gst-plugins10
+
+
+###
+# variable declarations
+###
+
+MY_PN=gst-plugins-ugly
+MY_P=${MY_PN}-${PV}
+# All relevant configure options for gst-plugins
+# need a better way to extract these
+# gst-plugins-base 0.9
+my_gst_plugins_ugly="amrnb a52dec lame mad mpeg2dec sidplay"
+
+#SRC_URI="mirror://gnome/sources/gst-plugins/${PV_MAJ_MIN}/${MY_P}.tar.bz2"
+SRC_URI="http://gstreamer.freedesktop.org/src/gst-plugins-good/${MY_P}.tar.bz2"
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND=">=media-libs/gst-plugins-base-0.9*"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+
+###
+# public functions
+###
+
+gst-plugins-ugly_src_configure() {
+
+ # disable any external plugin besides the plugin we want
+ local plugin gst_conf
+
+ einfo "Configuring to build ${GST_PLUGINS_BUILD} plugin(s) ..."
+
+ for plugin in ${GST_PLUGINS_BUILD}; do
+ my_gst_plugins_ugly=${my_gst_plugins_ugly/${plugin}/}
+ done
+ for plugin in ${my_gst_plugins_good}; do
+ gst_conf="${gst_conf} --disable-${plugin} "
+ done
+ for plugin in ${GST_PLUGINS_BUILD}; do
+ gst_conf="${gst_conf} --enable-${plugin} "
+ done
+
+ cd ${S}
+ econf ${@} ${gst_conf} || die "./configure failure"
+
+}
+
+###
+# public inheritable functions
+###
+
+gst-plugins-ugly_src_unpack() {
+
+ local makefiles
+
+ unpack ${A}
+
+ # Link with the syswide installed gst-libs if needed
+ gst-plugins10_find_plugin_dir
+ cd ${S}
+
+ # Remove generation of any other Makefiles except the plugin's Makefile
+ if [ -d "${S}/sys/${GST_PLUGINS_BUILD_DIR}" ]; then
+ makefiles="Makefile sys/Makefile sys/${GST_PLUGINS_BUILD_DIR}/Makefile"
+ elif [ -d "${S}/ext/${GST_PLUGINS_BUILD_DIR}" ]; then
+ makefiles="Makefile ext/Makefile ext/${GST_PLUGINS_BUILD_DIR}/Makefile"
+ fi
+ sed -e "s:ac_config_files=.*:ac_config_files='${makefiles}':" \
+ -i ${S}/configure
+
+}
+
+gst-plugins-ugly_src_compile() {
+
+ gst-plugins-ugly_src_configure ${@}
+
+ gst-plugins10_find_plugin_dir
+ emake || die "compile failure"
+
+}
+
+gst-plugins-ugly_src_install() {
+
+ gst-plugins10_find_plugin_dir
+ einstall || die
+
+ dodoc README
+}
+
+
+EXPORT_FUNCTIONS src_unpack src_compile src_install