summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-10-03 08:02:15 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-10-03 08:02:15 +0000
commit122a3380c53be43e1067a7d430c74de884923722 (patch)
treec38bb72917753785dc7e43110cdc90bc511fdd1f /eclass/kde.eclass
parentAdd akregator to the list of kdepim derived ebuilds. (diff)
downloadgentoo-2-122a3380c53be43e1067a7d430c74de884923722.tar.gz
gentoo-2-122a3380c53be43e1067a7d430c74de884923722.tar.bz2
gentoo-2-122a3380c53be43e1067a7d430c74de884923722.zip
Disable visibility support in kde programs in a different way (see bug #107571).
Diffstat (limited to 'eclass/kde.eclass')
-rw-r--r--eclass/kde.eclass12
1 files changed, 4 insertions, 8 deletions
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index c82f63ad8fa5..b9b10be39318 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.133 2005/09/25 21:03:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.134 2005/10/03 08:02:15 greg_g Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
#
@@ -59,13 +59,6 @@ kde_src_unpack() {
debug-print "$FUNCNAME: touching .ui files..."
touch $UIFILES
fi
-
- # Visiblity stuff *IS* broken. Just disable it when it's present.
- # DON'T make this version-dependent, it's NOT version dependant.
- if grep KDE_ENABLE_HIDDEN_VISIBILITY configure.in &> /dev/null || ! [[ -f configure ]]; then
- find ${S} -name configure.in.in | xargs sed -i -e 's:KDE_ENABLE_HIDDEN_VISIBILITY::g'
- rm -f configure
- fi
}
kde_src_compile() {
@@ -141,6 +134,9 @@ kde_src_compile() {
cd $S
+ # Visiblity stuff is broken. Just disable it when it's present.
+ export kde_cv_prog_cxx_fvisibility_hidden=no
+
# If we're not a kde-base ebuild, then set up the /usr directories properly
# Perhaps this could get changed later to use econf instead?
if [[ $PREFIX = "/usr" ]]; then