summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-07-15 08:08:12 +0000
committerNick Hadaway <raker@gentoo.org>2003-07-15 08:08:12 +0000
commitbaf08aa4ef954fac9095c9119194093b897eb740 (patch)
treedec4ab286c67e50e53a47d823697c6a4d2864c45 /eclass/gnustep.eclass
parentRemoving old files. (diff)
downloadgentoo-2-baf08aa4ef954fac9095c9119194093b897eb740.tar.gz
gentoo-2-baf08aa4ef954fac9095c9119194093b897eb740.tar.bz2
gentoo-2-baf08aa4ef954fac9095c9119194093b897eb740.zip
Got rid of egnustepmake and changed egnustepmake2 to egnustepmake
Diffstat (limited to 'eclass/gnustep.eclass')
-rw-r--r--eclass/gnustep.eclass54
1 files changed, 0 insertions, 54 deletions
diff --git a/eclass/gnustep.eclass b/eclass/gnustep.eclass
index 39a1a5aa68c8..af2e139793cd 100644
--- a/eclass/gnustep.eclass
+++ b/eclass/gnustep.eclass
@@ -37,60 +37,6 @@ egnustepmake() {
cd ${S}
- if [ -f /usr/GNUstep/System/Makefiles/GNUstep.sh ] ; then
- . /usr/GNUstep/System/Makefiles/GNUstep.sh
- else
- die "gnustep-make not installed!"
- fi
-
- mkdir -p $TMP/fakehome/GNUstep
-
- if [ -x configure ] ; then
- if [ -z "$*" ] ; then
- econf \
- HOME=$TMP/fakehome \
- GNUSTEP_USER_ROOT=$TMP/fakehome/GNUstep \
- || die "configure failed"
- else
- econf \
- HOME=$TMP/fakehome \
- GNUSTEP_USER_ROOT=$TMP/fakehome/GNUstep \
- $* || die "configure failed (options: $*)"
- fi
- fi
-
- if [ ! "${GNUSTEPBACK_XFT}" -eq 2 ] ; then
- if [ "${PN}" = "gnustep-back" ] ; then
- if [ ! -f "/usr/X11R6/include/X11/Xft1/Xft.h" ]; then
- sed "s,^#define HAVE_XFT.*,#undef HAVE_XFT,g" config.h > config.h.new
- sed "s,^#define HAVE_UTF8.*,#undef HAVE_UTF8,g" config.h.new > config.h
- sed "s,^WITH_XFT=.*,WITH_XFT=no," config.make > config.make.new
- sed "s,-lXft,," config.make.new > config.make
- fi
- fi
- fi
-
- if [ -f ./[mM]akefile -o -f ./GNUmakefile ] ; then
- make \
- HOME=$TMP/fakehome \
- GNUSTEP_USER_ROOT=$TMP/fakehome/GNUstep \
- || die "emake failed"
- else
- die "no Makefile found"
- fi
- return 0
-}
-
-# This was added for gnustep-guile and will provide an alternate
-# easier-to-swallow configure for gnustep programs that fail w/egnustepmake
-egnustepmake2() {
- getsourcedir
-
- addwrite ~/GNUstep/Defaults/.GNUstepDefaults.lck
- addpredict ~/GNUstep
-
- cd ${S}
-
unset CFLAGS
unset CC