summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-01 15:49:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-01 15:49:11 +0000
commit8e5565747608f1f4a8334e847b0260697ef90078 (patch)
tree6d469a1ed06c12953b2f1bf3584c3fbaab6c526e /eclass/bsdmk.eclass
parentRestricted test feature (diff)
downloadgentoo-2-8e5565747608f1f4a8334e847b0260697ef90078.tar.gz
gentoo-2-8e5565747608f1f4a8334e847b0260697ef90078.tar.bz2
gentoo-2-8e5565747608f1f4a8334e847b0260697ef90078.zip
Change depend to avoid using userland_BSD, don't use -Wl,-z,now but rather bindnow-flags for portability.
Diffstat (limited to 'eclass/bsdmk.eclass')
-rw-r--r--eclass/bsdmk.eclass13
1 files changed, 9 insertions, 4 deletions
diff --git a/eclass/bsdmk.eclass b/eclass/bsdmk.eclass
index bd749d4c93d4..10a5a13679bd 100644
--- a/eclass/bsdmk.eclass
+++ b/eclass/bsdmk.eclass
@@ -1,17 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/bsdmk.eclass,v 1.1 2006/04/01 15:24:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/bsdmk.eclass,v 1.2 2006/04/01 15:49:11 flameeyes Exp $
#
# Otavio R. Piske "AngusYoung" <angusyoung@gentoo.org>
# Diego Pettenò <flameeyes@gentoo.org>
# Benigno B. Junior <bbj@gentoo.org>
-inherit toolchain-funcs portability
+inherit toolchain-funcs portability flag-o-matic
EXPORT_FUNCTIONS src_compile src_install
+RDEPEND=""
# this should actually be BDEPEND, but this works.
-DEPEND="!userland_BSD? ( sys-devel/pmake )"
+DEPEND="|| (
+ sys-devel/pmake
+ sys-freebsd/freebsd-ubin
+ sys-openbsd/openbsd-ubin
+ )"
#### append-opt <options>
# append options to enable or disable features
@@ -57,7 +62,7 @@ dummy_mk() {
############################################################################
fix_lazy_bindings() {
for dir in $@; do
- echo "LDFLAGS+= -Wl,-z,now" >> ${dir}/Makefile
+ echo "LDFLAGS+= $(bindnow-flags)" >> ${dir}/Makefile
done
}