summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2012-12-30 15:46:31 +0000
committerDirkjan Ochtman <djc@gentoo.org>2012-12-30 15:46:31 +0000
commitc27a1a4be1ea0063e905f1e1630ea5a2883caa15 (patch)
tree13701d1695ca04038646e149da04963c366ee47d /dev-vcs
parentsh stable wrt #437414 (diff)
downloadgentoo-2-c27a1a4be1ea0063e905f1e1630ea5a2883caa15.tar.gz
gentoo-2-c27a1a4be1ea0063e905f1e1630ea5a2883caa15.tar.bz2
gentoo-2-c27a1a4be1ea0063e905f1e1630ea5a2883caa15.zip
Bring mercurial versions closer together.
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/ChangeLog6
-rw-r--r--dev-vcs/mercurial/mercurial-2.4.1-r1.ebuild14
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild63
3 files changed, 51 insertions, 32 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index cce02ba90fc5..54a234c0946c 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/mercurial
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.93 2012/12/30 15:21:57 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.94 2012/12/30 15:46:31 djc Exp $
+
+ 30 Dec 2012; Dirkjan Ochtman <djc@gentoo.org> mercurial-2.4.1-r1.ebuild,
+ mercurial-9999.ebuild:
+ Bring 2.4.1-r1 and 9999 versions closer together.
*mercurial-2.4.1-r1 (30 Dec 2012)
diff --git a/dev-vcs/mercurial/mercurial-2.4.1-r1.ebuild b/dev-vcs/mercurial/mercurial-2.4.1-r1.ebuild
index 5cd7c84df9c7..8cd59f11fafd 100644
--- a/dev-vcs/mercurial/mercurial-2.4.1-r1.ebuild
+++ b/dev-vcs/mercurial/mercurial-2.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.4.1-r1.ebuild,v 1.1 2012/12/30 15:21:57 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.4.1-r1.ebuild,v 1.2 2012/12/30 15:46:31 djc Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -26,7 +26,8 @@ RDEPEND="bugzilla? ( dev-python/mysql-python )
app-misc/ca-certificates"
DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
- dev-python/pygments )"
+ dev-python/pygments )
+ app-text/asciidoc"
PYTHON_CFLAGS=(
"2.* + -fno-strict-aliasing"
@@ -53,6 +54,7 @@ src_compile() {
fi
rm -rf contrib/{win32,macosx} || die
+ make doc || die
}
src_install() {
@@ -96,19 +98,19 @@ EOF
src_test() {
cd "${S}/tests/" || die
- rm -rf *svn* || die # Subversion tests fail with 1.5
- rm -f test-archive || die # Fails due to verbose tar output changes
+ rm -rf *svn* || die # Subversion tests fail with 1.5
+ rm -f test-archive || die # Fails due to verbose tar output changes
rm -f test-convert-baz* || die # GNU Arch baz
rm -f test-convert-cvs* || die # CVS
rm -f test-convert-darcs* || die # Darcs
rm -f test-convert-git* || die # git
rm -f test-convert-mtn* || die # monotone
rm -f test-convert-tla* || die # GNU Arch tla
- rm -f test-doctest* || die # doctest always fails with python 2.5.x
+ rm -f test-doctest* || die # doctest always fails with python 2.5.x
if [[ ${EUID} -eq 0 ]]; then
einfo "Removing tests which require user privileges to succeed"
rm -f test-command-template || die # Test is broken when run as root
- rm -f test-convert || die # Test is broken when run as root
+ rm -f test-convert || die # Test is broken when run as root
rm -f test-lock-badness || die # Test is broken when run as root
rm -f test-permissions || die # Test is broken when run as root
rm -f test-pull-permission || die # Test is broken when run as root
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index 88ad341ea6db..376808750b4d 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.13 2012/12/27 18:47:52 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.14 2012/12/30 15:46:31 djc Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -22,7 +22,8 @@ IUSE="bugzilla emacs gpg test tk zsh-completion"
RDEPEND="bugzilla? ( dev-python/mysql-python )
gpg? ( app-crypt/gnupg )
tk? ( dev-lang/tk )
- zsh-completion? ( app-shells/zsh )"
+ zsh-completion? ( app-shells/zsh )
+ app-misc/ca-certificates"
DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
dev-python/pygments )
@@ -36,6 +37,14 @@ PYTHON_CFLAGS=(
PYTHON_MODNAME="${PN} hgext"
SITEFILE="70${PN}-gentoo.el"
+src_prepare() {
+ distutils_src_prepare
+
+ # fix up logic that won't work in Gentoo Prefix (also won't outside in
+ # certain cases), bug #362891
+ sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
+}
+
src_compile() {
distutils_src_compile
@@ -44,12 +53,13 @@ src_compile() {
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
- rm -rf contrib/{win32,macosx}
+ rm -rf contrib/{win32,macosx} || die
make doc || die
}
src_install() {
distutils_src_install
+ python_convert_shebangs 2 contrib/hg-ssh
newbashcomp contrib/bash_completion ${PN} || die
@@ -58,17 +68,17 @@ src_install() {
newins contrib/zsh_completion _hg || die
fi
- rm -f doc/*.?.txt
- dodoc CONTRIBUTORS README doc/*.txt || die
+ rm -f doc/*.?.txt || die
+ dodoc CONTRIBUTORS PKG-INFO README doc/*.txt || die
cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
dobin hgeditor || die
dobin contrib/hgk || die
dobin contrib/hg-ssh || die
- rm -f contrib/hgk contrib/hg-ssh
+ rm -f contrib/hgk contrib/hg-ssh || die
- rm -f contrib/bash_completion
+ rm -f contrib/bash_completion || die
cp -r contrib "${ED}"/usr/share/doc/${PF}/ || die
doman doc/*.? || die
@@ -81,34 +91,37 @@ EOF
elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
+
+ insinto /etc/mercurial/hgrc.d
+ doins "${FILESDIR}/cacerts.rc"
}
src_test() {
cd "${S}/tests/" || die
- rm -rf *svn* # Subversion tests fail with 1.5
- rm -f test-archive # Fails due to verbose tar output changes
- rm -f test-convert-baz* # GNU Arch baz
- rm -f test-convert-cvs* # CVS
- rm -f test-convert-darcs* # Darcs
- rm -f test-convert-git* # git
- rm -f test-convert-mtn* # monotone
- rm -f test-convert-tla* # GNU Arch tla
- rm -f test-doctest* # doctest always fails with python 2.5.x
+ rm -rf *svn* || die # Subversion tests fail with 1.5
+ rm -f test-archive || die # Fails due to verbose tar output changes
+ rm -f test-convert-baz* || die # GNU Arch baz
+ rm -f test-convert-cvs* || die # CVS
+ rm -f test-convert-darcs* || die # Darcs
+ rm -f test-convert-git* || die # git
+ rm -f test-convert-mtn* || die # monotone
+ rm -f test-convert-tla* || die # GNU Arch tla
+ rm -f test-doctest* || die # doctest always fails with python 2.5.x
if [[ ${EUID} -eq 0 ]]; then
einfo "Removing tests which require user privileges to succeed"
- rm -f test-command-template # Test is broken when run as root
- rm -f test-convert # Test is broken when run as root
- rm -f test-lock-badness # Test is broken when run as root
- rm -f test-permissions # Test is broken when run as root
- rm -f test-pull-permission # Test is broken when run as root
- rm -f test-clone-failure
- rm -f test-journal-exists
- rm -f test-repair-strip
+ rm -f test-command-template || die # Test is broken when run as root
+ rm -f test-convert || die # Test is broken when run as root
+ rm -f test-lock-badness || die # Test is broken when run as root
+ rm -f test-permissions || die # Test is broken when run as root
+ rm -f test-pull-permission || die # Test is broken when run as root
+ rm -f test-clone-failure || die
+ rm -f test-journal-exists || die
+ rm -f test-repair-strip || die
fi
testing() {
local testdir="${T}/tests-${PYTHON_ABI}"
- rm -rf "${testdir}"
+ rm -rf "${testdir}" || die
"$(PYTHON)" run-tests.py --tmpdir="${testdir}"
}
python_execute_function testing