summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-03-08 19:22:34 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-03-08 19:22:34 +0000
commit01127c586679d8810e5a2dd9d75806baacbb072d (patch)
treede0e74dfa900fb9b9a452eef1280357ed02ecf35 /dev-vcs
parentStable on alpha, bug #355097 (diff)
downloadgentoo-2-01127c586679d8810e5a2dd9d75806baacbb072d.tar.gz
gentoo-2-01127c586679d8810e5a2dd9d75806baacbb072d.tar.bz2
gentoo-2-01127c586679d8810e5a2dd9d75806baacbb072d.zip
Version bump. Clean up old versions.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fossil/ChangeLog12
-rw-r--r--dev-vcs/fossil/files/20100318142033-gentoo.patch29
-rw-r--r--dev-vcs/fossil/fossil-20100918155143.ebuild39
-rw-r--r--dev-vcs/fossil/fossil-20101005035549.ebuild39
-rw-r--r--dev-vcs/fossil/fossil-20110301190432.ebuild (renamed from dev-vcs/fossil/fossil-20101101142335.ebuild)26
5 files changed, 24 insertions, 121 deletions
diff --git a/dev-vcs/fossil/ChangeLog b/dev-vcs/fossil/ChangeLog
index 91d793906c92..7f2357ef4aca 100644
--- a/dev-vcs/fossil/ChangeLog
+++ b/dev-vcs/fossil/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-vcs/fossil
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.7 2010/11/11 22:53:14 rafaelmartins Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.8 2011/03/08 19:22:34 rafaelmartins Exp $
+
+*fossil-20110301190432 (08 Mar 2011)
+
+ 08 Mar 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+ -files/20100318142033-gentoo.patch, -fossil-20100918155143.ebuild,
+ -fossil-20101005035549.ebuild, -fossil-20101101142335.ebuild,
+ +fossil-20110301190432.ebuild:
+ Version bump. Clean up old versions.
*fossil-20101111133638 (11 Nov 2010)
diff --git a/dev-vcs/fossil/files/20100318142033-gentoo.patch b/dev-vcs/fossil/files/20100318142033-gentoo.patch
deleted file mode 100644
index 751327cf56c7..000000000000
--- a/dev-vcs/fossil/files/20100318142033-gentoo.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 18d5ea5..962e295 100644
---- a/Makefile
-+++ b/Makefile
-@@ -40,7 +40,8 @@ TCC += -DFOSSIL_ENABLE_SSL
- # so that we can build a static executable that will run in a
- # chroot jail.
- #
--LIB = -lz $(LDFLAGS)
-+
-+LIB = -lz -lsqlite3
- # If you're on OpenSolaris:
- # LIB += lsocket
- # Solaris 10 needs:
-diff --git a/src/main.mk b/src/main.mk
-index 470bedd..a8bbc38 100644
---- a/src/main.mk
-+++ b/src/main.mk
-@@ -266,8 +266,8 @@ VERSION.h: $(SRCDIR)/../manifest.uuid $(SRCDIR)/../manifest
- awk '{ printf "#define MANIFEST_VERSION \"[%.10s]\"\n", $$1}' $(SRCDIR)/../manifest.uuid >>VERSION.h
- awk '$$1=="D"{printf "#define MANIFEST_DATE \"%s %s\"\n", substr($$2,1,10),substr($$2,12)}' $(SRCDIR)/../manifest >>VERSION.h
-
--$(APPNAME): headers $(OBJ) $(OBJDIR)/sqlite3.o $(OBJDIR)/th.o $(OBJDIR)/th_lang.o
-- $(TCC) -o $(APPNAME) $(OBJ) $(OBJDIR)/sqlite3.o $(OBJDIR)/th.o $(OBJDIR)/th_lang.o $(LIB)
-+$(APPNAME): headers $(OBJ) $(OBJDIR)/th.o $(OBJDIR)/th_lang.o
-+ $(TCC) $(LDFLAGS) -o $(APPNAME) $(OBJ) $(OBJDIR)/th.o $(OBJDIR)/th_lang.o $(LIB)
-
- # This rule prevents make from using its default rules to try build
- # an executable named "manifest" out of the file named "manifest.c"
diff --git a/dev-vcs/fossil/fossil-20100918155143.ebuild b/dev-vcs/fossil/fossil-20100918155143.ebuild
deleted file mode 100644
index ec8ee9d2b87b..000000000000
--- a/dev-vcs/fossil/fossil-20100918155143.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20100918155143.ebuild,v 1.2 2010/10/20 05:31:21 rafaelmartins Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-MY_P="${PN}-src-${PV}"
-PATCH_PV="20100318142033"
-
-DESCRIPTION="simple, high-reliability, distributed software configuration management"
-HOMEPAGE="http://www.fossil-scm.org/"
-SRC_URI="http://www.fossil-scm.org/download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=dev-db/sqlite-3.7.0
- dev-libs/openssl
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PATCH_PV}-gentoo.patch"
- sed -i \
- -e "/^TCC *=/s:=.*:=$(tc-getCC) -Wall \$(CFLAGS) \$(CPPFLAGS):" \
- -e "/^BCC/s:gcc:$(tc-getBUILD_CC):" \
- Makefile || die 'sed failed.'
-}
-
-src_install() {
- dobin fossil || die 'dobin failed.'
- dodoc ci_cvs.txt ci_fossil.txt cvs2fossil.txt || die 'dodoc failed.'
-}
diff --git a/dev-vcs/fossil/fossil-20101005035549.ebuild b/dev-vcs/fossil/fossil-20101005035549.ebuild
deleted file mode 100644
index 3b0de6d432b8..000000000000
--- a/dev-vcs/fossil/fossil-20101005035549.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20101005035549.ebuild,v 1.2 2010/10/20 05:31:21 rafaelmartins Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-MY_P="${PN}-src-${PV}"
-PATCH_PV="20100318142033"
-
-DESCRIPTION="simple, high-reliability, distributed software configuration management"
-HOMEPAGE="http://www.fossil-scm.org/"
-SRC_URI="http://www.fossil-scm.org/download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=dev-db/sqlite-3.7.0
- dev-libs/openssl
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PATCH_PV}-gentoo.patch"
- sed -i \
- -e "/^TCC *=/s:=.*:=$(tc-getCC) -Wall \$(CFLAGS) \$(CPPFLAGS):" \
- -e "/^BCC/s:gcc:$(tc-getBUILD_CC):" \
- Makefile || die 'sed failed.'
-}
-
-src_install() {
- dobin fossil || die 'dobin failed.'
- dodoc ci_cvs.txt ci_fossil.txt cvs2fossil.txt || die 'dodoc failed.'
-}
diff --git a/dev-vcs/fossil/fossil-20101101142335.ebuild b/dev-vcs/fossil/fossil-20110301190432.ebuild
index d7dda6f8cdea..70399c9e36b6 100644
--- a/dev-vcs/fossil/fossil-20101101142335.ebuild
+++ b/dev-vcs/fossil/fossil-20110301190432.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20101101142335.ebuild,v 1.1 2010/11/02 06:34:58 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20110301190432.ebuild,v 1.1 2011/03/08 19:22:34 rafaelmartins Exp $
EAPI="2"
@@ -15,21 +15,23 @@ SRC_URI="http://www.fossil-scm.org/download/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="+ssl"
-DEPEND=">=dev-db/sqlite-3.7.0
- dev-libs/openssl
- sys-libs/zlib"
+DEPEND="sys-libs/zlib
+ ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-src_prepare() {
- epatch "${FILESDIR}/${PV}-gentoo.patch"
- sed -i \
- -e "/^TCC *=/s:=.*:=$(tc-getCC) -Wall \$(CFLAGS) \$(CPPFLAGS):" \
- -e "/^BCC/s:gcc:$(tc-getBUILD_CC):" \
- Makefile || die 'sed failed.'
+src_compile() {
+ local tcc lib
+ tcc="$(tc-getCC)"
+ lib="${LDFLAGS} -lz"
+ if use ssl; then
+ tcc="${tcc} -DFOSSIL_ENABLE_SSL"
+ lib="${lib} -lcrypto -lssl"
+ fi
+ emake TCC="${tcc}" BCC="$(tc-getBUILD_CC)" LIB="${lib}" || die 'emake failed.'
}
src_install() {