summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2012-12-03 19:20:25 +0000
committerSebastian Pipping <sping@gentoo.org>2012-12-03 19:20:25 +0000
commitba49b923b7c13aa07f6744f766a9fd4cb298a35b (patch)
treeb9b91de9f78f0a8768a0788f8f0349ed470e7b99 /dev-vcs/svn2git
parentVersion bump. (diff)
downloadgentoo-2-ba49b923b7c13aa07f6744f766a9fd4cb298a35b.tar.gz
gentoo-2-ba49b923b7c13aa07f6744f766a9fd4cb298a35b.tar.bz2
gentoo-2-ba49b923b7c13aa07f6744f766a9fd4cb298a35b.zip
dev-vcs/svn2git: 1.0.8
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'dev-vcs/svn2git')
-rw-r--r--dev-vcs/svn2git/ChangeLog8
-rw-r--r--dev-vcs/svn2git/files/svn2git-1.0.8-compile.patch26
-rw-r--r--dev-vcs/svn2git/files/svn2git-1.0.8-version.patch14
-rw-r--r--dev-vcs/svn2git/svn2git-1.0.8.ebuild48
4 files changed, 95 insertions, 1 deletions
diff --git a/dev-vcs/svn2git/ChangeLog b/dev-vcs/svn2git/ChangeLog
index 5e8fcdf71681..63c0a336a6e0 100644
--- a/dev-vcs/svn2git/ChangeLog
+++ b/dev-vcs/svn2git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/svn2git
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.16 2012/12/02 18:25:42 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.17 2012/12/03 19:20:25 sping Exp $
+
+*svn2git-1.0.8 (03 Dec 2012)
+
+ 03 Dec 2012; Sebastian Pipping <sping@gentoo.org> +svn2git-1.0.8.ebuild,
+ +files/svn2git-1.0.8-compile.patch, +files/svn2git-1.0.8-version.patch:
+ Bump to 1.0.8
*svn2git-1.0.6 (02 Dec 2012)
diff --git a/dev-vcs/svn2git/files/svn2git-1.0.8-compile.patch b/dev-vcs/svn2git/files/svn2git-1.0.8-compile.patch
new file mode 100644
index 000000000000..730c51c9fb3f
--- /dev/null
+++ b/dev-vcs/svn2git/files/svn2git-1.0.8-compile.patch
@@ -0,0 +1,26 @@
+From b5c3d3aa55621c44db439e4a73884e0d0bf9612c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ulrich=20Sp=C3=B6rlein?= <uqs@spoerlein.net>
+Date: Wed, 28 Nov 2012 21:58:44 +0100
+Subject: [PATCH] Fix compilation, the last rebase/merge went wrong.
+
+Noticed by: Andy Pilate
+---
+ src/svn.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/svn.cpp b/src/svn.cpp
+index 1aadce9..b2fe2a2 100644
+--- a/src/svn.cpp
++++ b/src/svn.cpp
+@@ -896,7 +896,7 @@ int SvnRevision::recurse(const char *path, const svn_fs_path_change_t *change,
+ rev_from, changes, current, *match, matchRules, dirpool) == EXIT_FAILURE)
+ return EXIT_FAILURE;
+ } else {
+- if (dirent->kind == svn_node_dir) {
++ if (i.value() == svn_node_dir) {
+ qDebug() << current << "rev" << revnum
+ << "did not match any rules; auto-recursing";
+ if (recurse(entry, change, entryFrom.isNull() ? 0 : entryFrom.constData(),
+--
+1.7.1
+
diff --git a/dev-vcs/svn2git/files/svn2git-1.0.8-version.patch b/dev-vcs/svn2git/files/svn2git-1.0.8-version.patch
new file mode 100644
index 000000000000..3eed1cb5bbcc
--- /dev/null
+++ b/dev-vcs/svn2git/files/svn2git-1.0.8-version.patch
@@ -0,0 +1,14 @@
+--- src/src.pro 2011-01-11 09:27:21.530166986 +0100
++++ src/src.pro 2011-01-11 09:30:55.743128934 +0100
+@@ -7,10 +7,7 @@
+ APR_INCLUDE = /usr/include/apr-1
+ exists(local-config.pri):include(local-config.pri)
+
+-VERSION = $$system(git --no-pager show --pretty=oneline --no-notes | head -1 | cut -b-40)
+- !isEmpty(VERSION){
+- VERSION = $${VERSION}
+- }
++VERSION = "1.0.8"
+
+ VERSTR = '\\"$${VERSION}\\"' # place quotes around the version string
+ DEFINES += VER=\"$${VERSTR}\" # create a VER macro containing the version string
diff --git a/dev-vcs/svn2git/svn2git-1.0.8.ebuild b/dev-vcs/svn2git/svn2git-1.0.8.ebuild
new file mode 100644
index 000000000000..efc390b3f03a
--- /dev/null
+++ b/dev-vcs/svn2git/svn2git-1.0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-1.0.8.ebuild,v 1.1 2012/12/03 19:20:25 sping Exp $
+
+EAPI="2"
+
+inherit eutils qt4-r2
+[ "$PV" == "9999" ] && inherit git
+
+DESCRIPTION="Tool for one-time conversion from svn to git."
+HOMEPAGE="http://gitorious.org/svn2git/svn2git"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="dev-vcs/subversion
+ x11-libs/qt-core:4"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+S=${WORKDIR}/${PN}-${PN}
+
+src_prepare() {
+ # Note: patching order matters
+ epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
+ if [[ "$PV" != "9999" ]]; then
+ epatch "${FILESDIR}"/${P}-version.patch
+ fi
+ epatch "${FILESDIR}"/${P}-compile.patch
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/${PN}/samples
+ doins samples/*.rules || die 'doins failed'
+ dobin svn-all-fast-export || die 'dobin failed'
+ dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}