summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-06-30 00:18:23 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-06-30 00:18:23 +0000
commit2560f972eafeb31765dd947b813c2ae3d3f981ad (patch)
treeb2ac43c6c103a311501dc06eb1c8bd7ac4ab6f9e /dev-vcs/monotone
parentInitial import adopted from last-hope overlay. (diff)
downloadgentoo-2-2560f972eafeb31765dd947b813c2ae3d3f981ad.tar.gz
gentoo-2-2560f972eafeb31765dd947b813c2ae3d3f981ad.tar.bz2
gentoo-2-2560f972eafeb31765dd947b813c2ae3d3f981ad.zip
Fix building against boost-1.53, bug #454160.
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-vcs/monotone')
-rw-r--r--dev-vcs/monotone/ChangeLog6
-rw-r--r--dev-vcs/monotone/files/monotone-1.0-boost-1.53.patch92
-rw-r--r--dev-vcs/monotone/monotone-1.0-r3.ebuild5
3 files changed, 100 insertions, 3 deletions
diff --git a/dev-vcs/monotone/ChangeLog b/dev-vcs/monotone/ChangeLog
index a1fe65b01728..b7745cbdbed0 100644
--- a/dev-vcs/monotone/ChangeLog
+++ b/dev-vcs/monotone/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/monotone
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/ChangeLog,v 1.25 2013/02/16 12:39:34 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/ChangeLog,v 1.26 2013/06/30 00:18:23 chithanh Exp $
+
+ 30 Jun 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/monotone-1.0-boost-1.53.patch, monotone-1.0-r3.ebuild:
+ Fix building against boost-1.53, bug #454160.
16 Feb 2013; Pacho Ramos <pacho@gentoo.org> -monotone-1.0-r2.ebuild,
metadata.xml:
diff --git a/dev-vcs/monotone/files/monotone-1.0-boost-1.53.patch b/dev-vcs/monotone/files/monotone-1.0-boost-1.53.patch
new file mode 100644
index 000000000000..e72a57e4cdee
--- /dev/null
+++ b/dev-vcs/monotone/files/monotone-1.0-boost-1.53.patch
@@ -0,0 +1,92 @@
+============================================================
+--- src/database.cc 87efeeff2d3263ba98af684a4022f1897434ed2d
++++ src/database.cc 39ab2644b936e09a536b99ebd28b93f6e0d7c162
+@@ -92,7 +92,7 @@ using boost::shared_ptr;
+ using std::accumulate;
+
+ using boost::shared_ptr;
+-using boost::shared_dynamic_cast;
++using boost::dynamic_pointer_cast;
+ using boost::lexical_cast;
+ using boost::get;
+ using boost::tuple;
+@@ -3430,7 +3430,7 @@ database::encrypt_rsa(key_id const & pub
+
+ shared_ptr<X509_PublicKey> x509_key(Botan::X509::load_key(pub_block));
+ shared_ptr<RSA_PublicKey> pub_key
+- = shared_dynamic_cast<RSA_PublicKey>(x509_key);
++ = dynamic_pointer_cast<RSA_PublicKey>(x509_key);
+ if (!pub_key)
+ throw recoverable_failure(origin::system,
+ "Failed to get RSA encrypting key");
+@@ -3481,7 +3481,7 @@ database::check_signature(key_id const &
+ L(FL("building verifier for %d-byte pub key") % pub_block.size());
+ shared_ptr<X509_PublicKey> x509_key(Botan::X509::load_key(pub_block));
+ shared_ptr<RSA_PublicKey> pub_key
+- = boost::shared_dynamic_cast<RSA_PublicKey>(x509_key);
++ = boost::dynamic_pointer_cast<RSA_PublicKey>(x509_key);
+
+ E(pub_key, id.inner().made_from,
+ F("failed to get RSA verifying key for %s") % id);
+============================================================
+--- src/key_store.cc b7859345f7c665914d16357409bdff24a48b7996
++++ src/key_store.cc 1ca13b7ee527bc2872d9fc325cf5ef327ca053c2
+@@ -43,7 +43,7 @@ using boost::shared_ptr;
+
+ using boost::scoped_ptr;
+ using boost::shared_ptr;
+-using boost::shared_dynamic_cast;
++using boost::dynamic_pointer_cast;
+
+ using Botan::RSA_PrivateKey;
+ using Botan::RSA_PublicKey;
+@@ -641,7 +641,7 @@ key_store_state::decrypt_private_key(key
+ I(pkcs8_key);
+
+ shared_ptr<RSA_PrivateKey> priv_key;
+- priv_key = shared_dynamic_cast<RSA_PrivateKey>(pkcs8_key);
++ priv_key = dynamic_pointer_cast<RSA_PrivateKey>(pkcs8_key);
+ E(priv_key, origin::no_fault,
+ F("failed to extract RSA private key from PKCS#8 keypair"));
+
+@@ -879,7 +879,8 @@ key_store::make_signature(database & db,
+ L(FL("make_signature: building %d-byte pub key") % pub_block.size());
+ shared_ptr<X509_PublicKey> x509_key =
+ shared_ptr<X509_PublicKey>(Botan::X509::load_key(pub_block));
+- shared_ptr<RSA_PublicKey> pub_key = shared_dynamic_cast<RSA_PublicKey>(x509_key);
++ shared_ptr<RSA_PublicKey> pub_key =
++ dynamic_pointer_cast<RSA_PublicKey>(x509_key);
+
+ if (!pub_key)
+ throw recoverable_failure(origin::system,
+@@ -1092,7 +1093,7 @@ key_store_state::migrate_old_key_pair
+ continue;
+ }
+
+- priv_key = shared_dynamic_cast<RSA_PrivateKey>(pkcs8_key);
++ priv_key = dynamic_pointer_cast<RSA_PrivateKey>(pkcs8_key);
+ I(priv_key);
+
+ // now we can write out the new key
+============================================================
+--- src/ssh_agent.cc 4a0dcab873559e934e41c5f220b5434d35600d9b
++++ src/ssh_agent.cc 6313ee3cdfca4112ba3957dc4a5f318472289dfa
+@@ -32,7 +32,7 @@ using boost::shared_ptr;
+ using std::vector;
+
+ using boost::shared_ptr;
+-using boost::shared_dynamic_cast;
++using boost::dynamic_pointer_cast;
+
+ using Botan::RSA_PublicKey;
+ using Botan::RSA_PrivateKey;
+@@ -391,7 +391,8 @@ ssh_agent::has_key(const keypair & key)
+ L(FL("has_key: building %d-byte pub key") % pub_block.size());
+ shared_ptr<X509_PublicKey> x509_key =
+ shared_ptr<X509_PublicKey>(Botan::X509::load_key(pub_block));
+- shared_ptr<RSA_PublicKey> pub_key = shared_dynamic_cast<RSA_PublicKey>(x509_key);
++ shared_ptr<RSA_PublicKey> pub_key =
++ dynamic_pointer_cast<RSA_PublicKey>(x509_key);
+
+ if (!pub_key)
+ throw recoverable_failure(origin::system,
diff --git a/dev-vcs/monotone/monotone-1.0-r3.ebuild b/dev-vcs/monotone/monotone-1.0-r3.ebuild
index dce6f560b928..41dbede17ea0 100644
--- a/dev-vcs/monotone/monotone-1.0-r3.ebuild
+++ b/dev-vcs/monotone/monotone-1.0-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/monotone-1.0-r3.ebuild,v 1.3 2012/06/07 22:13:04 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/monotone-1.0-r3.ebuild,v 1.4 2013/06/30 00:18:23 chithanh Exp $
# QA failiures reported in https://code.monotone.ca/p/monotone/issues/181/
EAPI="4"
@@ -41,6 +41,7 @@ src_prepare() {
epatch "${FILESDIR}/monotone-1.0-bash-completion-tests.patch"
epatch "${FILESDIR}/monotone-1.0-botan-1.10.patch"
epatch "${FILESDIR}/monotone-1.0-glibc-2.14-file-handle.patch"
+ epatch "${FILESDIR}/monotone-1.0-boost-1.53.patch"
}
src_configure() {