summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-07-21 15:47:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-07-21 15:47:28 +0000
commitf9b02a85a99b12d7495aff6b364cc1c510026606 (patch)
tree38efdb2846bb5a5f33c9cc396c298dc62a7bb8e3 /dev-vcs/gitosis-gentoo
parentMask media-libs/shivavg (diff)
downloadgentoo-2-f9b02a85a99b12d7495aff6b364cc1c510026606.tar.gz
gentoo-2-f9b02a85a99b12d7495aff6b364cc1c510026606.tar.bz2
gentoo-2-f9b02a85a99b12d7495aff6b364cc1c510026606.zip
Another verbump for minor bug.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/gitosis-gentoo')
-rw-r--r--dev-vcs/gitosis-gentoo/ChangeLog8
-rw-r--r--dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100721.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-vcs/gitosis-gentoo/ChangeLog b/dev-vcs/gitosis-gentoo/ChangeLog
index 8d75adca50f6..a5b52bf5d1ae 100644
--- a/dev-vcs/gitosis-gentoo/ChangeLog
+++ b/dev-vcs/gitosis-gentoo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/gitosis-gentoo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/ChangeLog,v 1.2 2010/07/21 03:36:59 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/ChangeLog,v 1.3 2010/07/21 15:47:28 robbat2 Exp $
+
+*gitosis-gentoo-0.2_p20100721 (21 Jul 2010)
+
+ 21 Jul 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +gitosis-gentoo-0.2_p20100721.ebuild:
+ Another verbump for minor bug.
*gitosis-gentoo-0.2_p20100718 (21 Jul 2010)
diff --git a/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100721.ebuild b/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100721.ebuild
new file mode 100644
index 000000000000..b80e6893a743
--- /dev/null
+++ b/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100721.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100721.ebuild,v 1.1 2010/07/21 15:47:28 robbat2 Exp $
+
+EAPI=3
+inherit eutils distutils
+
+DESCRIPTION="gitosis -- software for hosting git repositories, Gentoo fork"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/gitosis-gentoo.git"
+# This is a snapshot taken from the Gentoo overlays gitweb.
+MY_GITREV="9f39956b8b10e4952cdf0efb8462efd55c71926b"
+MY_PV="${PV}"
+MY_P="${PN}-${MY_PV}" # identical to P for now
+SRC_URI="http://git.overlays.gentoo.org/gitweb/?p=proj/gitosis-gentoo.git;a=snapshot;h=refs/tags/${PV};sf=tbz2 -> ${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+DEPEND_GIT=">=dev-vcs/git-1.5.6.4"
+DEPEND="${DEPEND_GIT}
+ >=dev-python/setuptools-0.6_rc5"
+RDEPEND="${DEPEND}
+ !dev-vcs/gitosis"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/sh /var/spool/gitosis git
+}
+
+src_compile() {
+ pwd
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/spool/gitosis
+ fowners git:git /var/spool/gitosis
+}
+
+# We should handle more of this, but it requires the input of an SSH public key
+# from the user, and they may want to set up more configuration first.
+#pkg_config() {
+#}
+
+pkg_postinst() {
+ einfo "If you need to actually use gitosis, you must unlock the git user."
+}