summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-31 12:39:29 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-31 12:39:29 +0000
commit103189550caaa45e0357e7347c6709187b362245 (patch)
treea645f8c7d5d2fb347af3ac8a70afa12892ba0015 /dev-vcs/gitinspector
parentrevert use dependency on app-emulation/qemu[usb,usbredir], this was a bad ide... (diff)
downloadgentoo-2-103189550caaa45e0357e7347c6709187b362245.tar.gz
gentoo-2-103189550caaa45e0357e7347c6709187b362245.tar.bz2
gentoo-2-103189550caaa45e0357e7347c6709187b362245.zip
dev-vcs/gitinspector: Fix for unknown LC_ALL, #527340
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-vcs/gitinspector')
-rw-r--r--dev-vcs/gitinspector/ChangeLog5
-rw-r--r--dev-vcs/gitinspector/gitinspector-0.3.2.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-vcs/gitinspector/ChangeLog b/dev-vcs/gitinspector/ChangeLog
index c907540daa09..ebc65cb39590 100644
--- a/dev-vcs/gitinspector/ChangeLog
+++ b/dev-vcs/gitinspector/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-vcs/gitinspector
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitinspector/ChangeLog,v 1.2 2014/06/23 06:59:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitinspector/ChangeLog,v 1.3 2014/10/31 12:39:29 jlec Exp $
+
+ 31 Oct 2014; Justin Lecher <jlec@gentoo.org> gitinspector-0.3.2.ebuild:
+ Fix for unknown LC_ALL, #527340
*gitinspector-0.3.2 (23 Jun 2014)
diff --git a/dev-vcs/gitinspector/gitinspector-0.3.2.ebuild b/dev-vcs/gitinspector/gitinspector-0.3.2.ebuild
index a352a24550ff..87feb3bca2e9 100644
--- a/dev-vcs/gitinspector/gitinspector-0.3.2.ebuild
+++ b/dev-vcs/gitinspector/gitinspector-0.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitinspector/gitinspector-0.3.2.ebuild,v 1.1 2014/06/23 06:59:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitinspector/gitinspector-0.3.2.ebuild,v 1.2 2014/10/31 12:39:29 jlec Exp $
EAPI=5
@@ -20,3 +20,8 @@ IUSE="test"
RDEPEND="dev-vcs/git"
DEPEND="
test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ [[ ${LC_ALL} == "C" ]] && export LC_ALL="en_US.utf8"
+ distutils-r1_python_prepare_all
+}