summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-03-04 20:29:37 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-03-04 20:29:37 +0000
commitc08907aa3534babb7f3720e4da512e6c76d82f98 (patch)
treed8b813f4692ea6d4fd9ec855b41408916a7a6b54 /dev-vcs/fossil
parentFix install of HTML doc. Bug #321571 (diff)
downloadgentoo-2-c08907aa3534babb7f3720e4da512e6c76d82f98.tar.gz
gentoo-2-c08907aa3534babb7f3720e4da512e6c76d82f98.tar.bz2
gentoo-2-c08907aa3534babb7f3720e4da512e6c76d82f98.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'dev-vcs/fossil')
-rw-r--r--dev-vcs/fossil/ChangeLog8
-rw-r--r--dev-vcs/fossil/fossil-20111213135356.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-vcs/fossil/ChangeLog b/dev-vcs/fossil/ChangeLog
index a2cb49bececd..add33bcb8424 100644
--- a/dev-vcs/fossil/ChangeLog
+++ b/dev-vcs/fossil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/fossil
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.10 2012/02/20 04:29:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.11 2012/03/04 20:29:37 titanofold Exp $
+
+*fossil-20111213135356 (04 Mar 2012)
+
+ 04 Mar 2012; Aaron W. Swenson <titanofold@gentoo.org>
+ +fossil-20111213135356.ebuild:
+ Version bump.
20 Feb 2012; Mike Gilbert <floppym@gentoo.org> metadata.xml:
Drop no-herd.
diff --git a/dev-vcs/fossil/fossil-20111213135356.ebuild b/dev-vcs/fossil/fossil-20111213135356.ebuild
new file mode 100644
index 000000000000..3e0c6a7d3464
--- /dev/null
+++ b/dev-vcs/fossil/fossil-20111213135356.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20111213135356.ebuild,v 1.1 2012/03/04 20:29:37 titanofold Exp $
+
+EAPI="4"
+
+MY_P="${PN}-src-${PV}"
+
+DESCRIPTION="Simple, high-reliability, distributed software configuration management"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sqlite +ssl tcl"
+
+DEPEND="sys-libs/zlib
+ ssl? ( dev-libs/openssl )
+ sqlite? ( dev-db/sqlite:3 )
+ tcl? ( dev-lang/tcl )
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf='--with-openssl='
+ use ssl && myconf+='auto' || myconf+='none'
+ use sqlite && myconf+=' --disable-internal-sqlite'
+ use tcl && myconf+=' --with-tcl'
+ econf ${myconf}
+}
+
+src_install() {
+ dobin fossil
+}