summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-04-04 13:43:12 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-04-04 13:43:12 +0000
commit123b22379e0948bdd2044ae48d175874fa979098 (patch)
treeafdb71270377f04bccd2cb66e991cba807aee404 /dev-vcs/cvs
parenttypo (diff)
downloadgentoo-2-123b22379e0948bdd2044ae48d175874fa979098.tar.gz
gentoo-2-123b22379e0948bdd2044ae48d175874fa979098.tar.bz2
gentoo-2-123b22379e0948bdd2044ae48d175874fa979098.zip
Fixed build failure (unknown type name 'intmax_t').
(Portage version: 2.2.0_alpha171_p2/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-vcs/cvs')
-rw-r--r--dev-vcs/cvs/ChangeLog6
-rw-r--r--dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild6
-rw-r--r--dev-vcs/cvs/files/cvs-1.12.13.1-use-include_next.patch30
3 files changed, 39 insertions, 3 deletions
diff --git a/dev-vcs/cvs/ChangeLog b/dev-vcs/cvs/ChangeLog
index 1a243f1e8bf4..8a735ae5d553 100644
--- a/dev-vcs/cvs/ChangeLog
+++ b/dev-vcs/cvs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/cvs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/ChangeLog,v 1.9 2013/02/18 04:41:20 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/ChangeLog,v 1.10 2013/04/04 13:43:12 slyfox Exp $
+
+ 04 Apr 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/cvs-1.12.13.1-use-include_next.patch, cvs-1.12.13.1-r1.ebuild:
+ Fixed build failure (unknown type name 'intmax_t').
18 Feb 2013; Zac Medico <zmedico@gentoo.org> cvs-1.12.12-r10.ebuild:
Add ~arm-linux keyword.
diff --git a/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild b/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild
index 49ff212f87be..926db59b5f50 100644
--- a/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild,v 1.1 2013/01/11 13:47:04 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild,v 1.2 2013/04/04 13:43:12 slyfox Exp $
EAPI=3
@@ -28,9 +28,10 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
IUSE="crypt doc kerberos nls pam server"
-DEPEND=">=sys-libs/zlib-1.1.4
+RDEPEND=">=sys-libs/zlib-1.1.4
kerberos? ( virtual/krb5 )
pam? ( virtual/pam )"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${P}.tar.bz2
@@ -44,6 +45,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.12.13.1-hash-nameclash.patch # for AIX
epatch "${FILESDIR}"/${PN}-1.12.13.1-gl-mempcpy.patch # for AIX
epatch "${FILESDIR}"/${PN}-1.12.12-fix-massive-leak.patch
+ epatch "${FILESDIR}"/${PN}-1.12.13.1-use-include_next.patch
# Applied by upstream:
#epatch "${FILESDIR}"/${PN}-1.12.13-openat.patch
#epatch "${FILESDIR}"/${PN}-1.12.13-zlib.patch
diff --git a/dev-vcs/cvs/files/cvs-1.12.13.1-use-include_next.patch b/dev-vcs/cvs/files/cvs-1.12.13.1-use-include_next.patch
new file mode 100644
index 000000000000..adaff55ebb16
--- /dev/null
+++ b/dev-vcs/cvs/files/cvs-1.12.13.1-use-include_next.patch
@@ -0,0 +1,30 @@
+Fix build failure on gentoo's gcc:
+
+In file included from ./inttypes.h:34:0,
+ from ./stdint.h:65,
+ from /usr/include/netinet/in.h:23,
+ from /usr/include/netdb.h:27,
+ from getaddrinfo.h:30,
+ from canon-host.c:27:
+ /usr/include/inttypes.h:297:1: error: unknown type name 'intmax_t'
+ /usr/include/inttypes.h:297:26: error: unknown type name 'intmax_t'
+ /usr/include/inttypes.h:300:27: error: unknown type name 'intmax_t'
+ /usr/include/inttypes.h:300:45: error: unknown type name 'intmax_t'
+diff --git a/lib/stdint_.h b/lib/stdint_.h
+index adab4d7..3a8db19 100644
+--- a/lib/stdint_.h
++++ b/lib/stdint_.h
+@@ -43,7 +43,12 @@
+ Include it before <inttypes.h>, since any "#include <stdint.h>"
+ in <inttypes.h> would reinclude us, skipping our contents because
+ _GL_STDINT_H is defined. */
+-# include @ABSOLUTE_STDINT_H@
++# include "config.h"
++# if HAVE_INCLUDE_NEXT
++# include_next <stdint.h>
++# else
++# include @ABSOLUTE_STDINT_H@
++# endif
+ #endif
+
+ /* <sys/types.h> defines some of the stdint.h types as well, on glibc,