summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-03-14 16:11:48 +0000
committerMarius Mauch <genone@gentoo.org>2004-03-14 16:11:48 +0000
commitf525ee0085e3f16c139f22c938a106b512029e7c (patch)
tree91c6faf4ef171864ed70ff8481a722203c4d5c06 /dev-util
parentVersion bump, new maintainer, and initial import of libosip2 ebuild (Manifest... (diff)
downloadgentoo-2-f525ee0085e3f16c139f22c938a106b512029e7c.tar.gz
gentoo-2-f525ee0085e3f16c139f22c938a106b512029e7c.tar.bz2
gentoo-2-f525ee0085e3f16c139f22c938a106b512029e7c.zip
version bump
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gambas/ChangeLog7
-rw-r--r--dev-util/gambas/files/digest-gambas-0.911
-rw-r--r--dev-util/gambas/gambas-0.91.ebuild76
3 files changed, 83 insertions, 1 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index a0b5fce4c511..117fb077b4bd 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/gambas
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.8 2004/03/08 21:18:33 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.9 2004/03/14 16:11:48 genone Exp $
+
+*gambas-0.91 (14 Mar 2004)
+
+ 14 Mar 2004; Marius Mauch <genone@gentoo.org> gambas-0.91.ebuild:
+ version bump
08 Mar 2004; Marius Mauch <genone@gentoo.org> gambas-0.90-r1.ebuild:
move /usr/lib/info/* to /usr/lib/gambas/info/
diff --git a/dev-util/gambas/files/digest-gambas-0.91 b/dev-util/gambas/files/digest-gambas-0.91
new file mode 100644
index 000000000000..e710175b09c4
--- /dev/null
+++ b/dev-util/gambas/files/digest-gambas-0.91
@@ -0,0 +1 @@
+MD5 de4f38111c8657332670bb241a1b1f56 gambas-0.91.tar.bz2 2711923
diff --git a/dev-util/gambas/gambas-0.91.ebuild b/dev-util/gambas/gambas-0.91.ebuild
new file mode 100644
index 000000000000..ac03332c8680
--- /dev/null
+++ b/dev-util/gambas/gambas-0.91.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.91.ebuild,v 1.1 2004/03/14 16:11:48 genone Exp $
+
+inherit eutils
+
+DESCRIPTION="a RAD tool for BASIC"
+HOMEPAGE="http://gambas.sourceforge.net"
+SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="postgres mysql sdl doc curl debug"
+DEPEND=">=sys-devel/automake-1.7.5
+ >=x11-base/xfree-4.3.0
+ >=x11-libs/qt-3.2
+ >=kde-base/kdelibs-3.2
+ sdl? ( media-libs/libsdl )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ curl? ( net-ftp/curl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:-Os::' configure
+ # replace braindead Makefile
+ rm Makefile*
+ cp "${FILESDIR}/Makefile.am-0.90" ./Makefile.am
+ automake
+ # patches against hardcoded paths
+ epatch ${FILESDIR}/non-symlink-0.90.patch
+ epatch ${FILESDIR}/info-location-0.90.patch
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --enable-kde --enable-qt"
+ myconf="${myconf} `use_enable mysql`"
+ myconf="${myconf} `use_enable postgres`"
+ myconf="${myconf} `use_enable sdl`"
+ myconf="${myconf} `use_enable curl`"
+
+ if use debug; then
+ myconf="${myconf} --disable-optimization --enable-debug"
+ else
+ myconf="${myconf} --enable-optimization --disable-debug"
+ fi
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ export PATH="${D}/usr/bin:${PATH}"
+ einstall || die
+
+ dodoc README INSTALL NEWS AUTHORS ChangeLog COPYING TODO
+
+ # only install the API docs and examples with USE=doc
+ if use doc; then
+ mv ${D}/usr/share/help ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/examples ${D}/usr/share/doc/${PF}/examples
+ einfo "Compiling examples ..."
+ cd ${D}/usr/share/doc/${PF}/examples
+ for p in *; do
+ cd $p
+ gbc -ag
+ gba
+ cd ..
+ done
+ fi
+ rm -rf ${D}/usr/share/help ${D}/usr/share/examples
+}