summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-03-30 16:53:34 +0000
committerJeroen Roovers <jer@gentoo.org>2014-03-30 16:53:34 +0000
commitd72970a70eaff66a94f9b84d57793a0194ae2995 (patch)
treea806f6b5c9214f72ed037deda0cd708e23a00091 /dev-util
parentRevert back to ~arch because arch stabilization can't be trusted due to the b... (diff)
downloadgentoo-2-d72970a70eaff66a94f9b84d57793a0194ae2995.tar.gz
gentoo-2-d72970a70eaff66a94f9b84d57793a0194ae2995.tar.bz2
gentoo-2-d72970a70eaff66a94f9b84d57793a0194ae2995.zip
Version bump by Christian Strahl (bug #503320). Do not use bundled tinyxml2 (bug #506248 by Jérôme Borme). Set up src_test().
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppcheck/ChangeLog9
-rw-r--r--dev-util/cppcheck/cppcheck-1.64.ebuild74
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.64-tinyxml2.patch30
3 files changed, 112 insertions, 1 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index fc91bfb6ad92..8f2c1d286b0b 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.48 2014/01/14 13:59:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.49 2014/03/30 16:53:34 jer Exp $
+
+*cppcheck-1.64 (30 Mar 2014)
+
+ 30 Mar 2014; Jeroen Roovers <jer@gentoo.org> +cppcheck-1.64.ebuild,
+ +files/cppcheck-1.64-tinyxml2.patch:
+ Version bump by Christian Strahl (bug #503320). Do not use bundled tinyxml2
+ (bug #506248 by Jérôme Borme). Set up src_test().
14 Jan 2014; Agostino Sarubbo <ago@gentoo.org> cppcheck-1.62.ebuild:
Stable for x86, wrt bug #497560
diff --git a/dev-util/cppcheck/cppcheck-1.64.ebuild b/dev-util/cppcheck/cppcheck-1.64.ebuild
new file mode 100644
index 000000000000..934ffe7a9bf7
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.64.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.64.ebuild,v 1.1 2014/03/30 16:53:34 jer Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+DEPEND="htmlreport? ( ${PYTHON_DEPS} )
+ >=dev-libs/tinyxml2-2
+ qt4? ( dev-qt/qtgui:4 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Do not use bundled tinyxml2
+ epatch "${FILESDIR}"/${P}-tinyxml2.patch
+}
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake \
+ CFGDIR="/usr/share/${PN}/cfg" \
+ TINYXML="-ltinyxml2"
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils-r1_src_compile
+ popd
+ fi
+}
+
+src_test() {
+ emake TINYXML="-ltinyxml2" check
+}
+
+src_install() {
+ emake install DESTDIR="${D}" TINYXML="-ltinyxml2"
+ dodoc readme.txt
+ insinto "/usr/share/${PN}/cfg"
+ doins cfg/*.cfg
+ if use qt4 ; then
+ dobin gui/${PN}-gui
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck}
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils-r1_src_install
+ popd
+ find "${D}" -name "*.egg-info" -delete
+ fi
+}
diff --git a/dev-util/cppcheck/files/cppcheck-1.64-tinyxml2.patch b/dev-util/cppcheck/files/cppcheck-1.64-tinyxml2.patch
new file mode 100644
index 000000000000..e694efa95458
--- /dev/null
+++ b/dev-util/cppcheck/files/cppcheck-1.64-tinyxml2.patch
@@ -0,0 +1,30 @@
+--- a/Makefile
++++ b/Makefile
+@@ -81,15 +81,15 @@
+ endif
+
+ ifndef INCLUDE_FOR_LIB
+- INCLUDE_FOR_LIB=-Ilib -Iexternals -Iexternals/tinyxml
++ INCLUDE_FOR_LIB=-Ilib
+ endif
+
+ ifndef INCLUDE_FOR_CLI
+- INCLUDE_FOR_CLI=-Ilib -Iexternals -Iexternals/tinyxml
++ INCLUDE_FOR_CLI=-Ilib
+ endif
+
+ ifndef INCLUDE_FOR_TEST
+- INCLUDE_FOR_TEST=-Ilib -Icli -Iexternals -Iexternals/tinyxml
++ INCLUDE_FOR_TEST=-Ilib -Icli
+ endif
+
+ BIN=$(DESTDIR)$(PREFIX)/bin
+@@ -226,7 +226,7 @@
+ $(CXX) -std=c++0x -o dmake tools/dmake.cpp cli/filelister.cpp lib/path.cpp -Ilib $(LDFLAGS)
+
+ reduce: tools/reduce.cpp
+- $(CXX) -std=c++0x -g -o reduce tools/reduce.cpp -Ilib -Iexternals/tinyxml lib/*.cpp externals/tinyxml/tinyxml2.cpp
++ $(CXX) -std=c++0x -g -o reduce tools/reduce.cpp -Ilib lib/*.cpp
+
+ clean:
+ rm -f build/*.o lib/*.o cli/*.o test/*.o externals/tinyxml/*.o testrunner reduce cppcheck cppcheck.1