summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-01-01 19:51:53 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-01-01 19:51:53 +0000
commitcb085d88c19f9a968e7dfe4d7247331f4dab6cb5 (patch)
tree7defb630358d1d3b3203aa38aaebd44a757c339e /dev-util
parentadd ewarn to 0.28 ebuild about account droping, (diff)
downloadgentoo-2-cb085d88c19f9a968e7dfe4d7247331f4dab6cb5.tar.gz
gentoo-2-cb085d88c19f9a968e7dfe4d7247331f4dab6cb5.tar.bz2
gentoo-2-cb085d88c19f9a968e7dfe4d7247331f4dab6cb5.zip
Version bump, granted by robbat2 as test-suite passes
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog9
-rw-r--r--dev-util/git/files/digest-git-1.5.4_rc29
-rw-r--r--dev-util/git/git-1.5.4_rc2.ebuild225
3 files changed, 241 insertions, 2 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 79c05e60de27..39ff2aab243f 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.246 2007/12/29 10:41:59 welp Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.247 2008/01/01 19:51:52 jokey Exp $
+
+*git-1.5.4_rc2 (01 Jan 2008)
+
+ 01 Jan 2008; Markus Ullmann <jokey@gentoo.org> +git-1.5.4_rc2.ebuild:
+ Version bump, granted by robbat2 as test-suite passes
29 Dec 2007; <welp@gentoo.org> git-1.5.4_rc1.ebuild:
Keyworded ~sparc-fbsd; bug 203655
diff --git a/dev-util/git/files/digest-git-1.5.4_rc2 b/dev-util/git/files/digest-git-1.5.4_rc2
new file mode 100644
index 000000000000..99d4bf9cbf1a
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.5.4_rc2
@@ -0,0 +1,9 @@
+MD5 adbba0e69f6d6163ebce70aaff9dd4e6 git-1.5.4.rc2.tar.bz2 1550103
+RMD160 96b857d72d10287366a634a63294caa336850c6d git-1.5.4.rc2.tar.bz2 1550103
+SHA256 48f86c8be2f5315b7a178f74a0d01a120be5119eeeee465fd7ef60c1740d6014 git-1.5.4.rc2.tar.bz2 1550103
+MD5 b8caaaed47b1aaf32b0edc9cc5a75a68 git-htmldocs-1.5.4.rc2.tar.bz2 603097
+RMD160 b530069db8852d78a373c5eb1874ac189f624502 git-htmldocs-1.5.4.rc2.tar.bz2 603097
+SHA256 03516a441af5f0881a1064e44acf3638a083a23c650b13ba24036facd5b8b712 git-htmldocs-1.5.4.rc2.tar.bz2 603097
+MD5 d6407ab46ab3d5070c521bda6e0c141a git-manpages-1.5.4.rc2.tar.bz2 154985
+RMD160 4c3d8eb5e907a56c6a3f6f8eafc247ab3201bd6e git-manpages-1.5.4.rc2.tar.bz2 154985
+SHA256 6e4bcdb992c710ac2b6b698a68cca2ada050db85979fb31e59015c0718686c39 git-manpages-1.5.4.rc2.tar.bz2 154985
diff --git a/dev-util/git/git-1.5.4_rc2.ebuild b/dev-util/git/git-1.5.4_rc2.ebuild
new file mode 100644
index 000000000000..ece8366de490
--- /dev/null
+++ b/dev-util/git/git-1.5.4_rc2.ebuild
@@ -0,0 +1,225 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.5.4_rc2.ebuild,v 1.1 2008/01/01 19:51:52 jokey Exp $
+
+inherit toolchain-funcs eutils elisp-common perl-module bash-completion
+
+MY_PV="${PV/_rc/.rc}"
+MY_P="${PN}-${MY_PV}"
+
+DOC_VER=${MY_PV}
+
+DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="curl cgi doc emacs gtk iconv mozsha1 perl ppcsha1 tk webdav"
+
+DEPEND="
+ !app-misc/git
+ dev-libs/openssl
+ sys-libs/zlib
+ dev-lang/perl
+ app-arch/cpio
+ tk? ( dev-lang/tk )
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ cgi? ( virtual/perl-CGI )
+ perl? ( dev-perl/Error )
+ gtk? ( >=dev-python/pygtk-2.8 )"
+
+SITEFILE=72${PN}-gentoo.el
+S="${WORKDIR}/${MY_P}"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ use iconv || myopts="${myopts} NO_ICONV=YesPlease"
+ use tk || myopts="${myopts} NO_TCLTK=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ elog " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ unpack ${PN}-manpages-${DOC_VER}.tar.bz2
+ use doc && cd "${S}"/Documentation && unpack ${PN}-htmldocs-${DOC_VER}.tar.bz2
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.5.3-symlinks.patch
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ -e 's:ln :ln -s :g' \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+ if use cgi ; then
+ emake ${MY_MAKEOPTS} \
+ DESTDIR="${D}" \
+ prefix=/usr \
+ gitweb/gitweb.cgi || die "make gitweb/gitweb.cgi failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || \
+ die "make install failed"
+
+ doman man?/*
+
+ dodoc README Documentation/{SubmittingPatches,CodingGuidelines}
+ use doc && dodir /usr/share/doc/${PF}/html
+ for d in / /howto/ /technical/ ; do
+ einfo "Doing Documentation${d}"
+ docinto ${d}
+ dodoc Documentation${d}*.txt
+ use doc && dohtml -p ${d} Documentation${d}*.html
+ done
+ docinto /
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ elisp-install ${PN} contrib/emacs/{,vc-}git.el* || \
+ die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ # don't add automatically to the load-path, so the sitefile
+ # can do a conditional loading
+ touch "${D}"/"${SITELISP}"/${PN}/.nosearch
+ fi
+
+ if use gtk ; then
+ dobin "${S}"/contrib/gitview/gitview
+ dodoc "${S}"/contrib/gitview/gitview.txt
+ newbin "${S}"/contrib/blameview/blameview.perl blameview
+ newdoc "${S}"/contrib/blameview/README README.blameview
+ fi
+
+ dobin contrib/fast-import/git-p4
+ dodoc contrib/fast-import/git-p4.txt
+ newbin contrib/fast-import/import-tars.perl import-tars
+
+ dodir /usr/share/${PN}/contrib
+ # The following are excluded:
+ # p4import - excluded because fast-import has a better one
+ # examples - these are stuff that is not used in Git anymore actually
+ # patches - stuff the Git guys made to go upstream to other places
+ for i in continuous fast-import hg-to-git \
+ hooks remotes2config.sh vim stats \
+ workdir convert-objects ; do
+ cp -rf \
+ "${S}"/contrib/${i} \
+ "${D}"/usr/share/${PN}/contrib \
+ || die "Failed contrib ${i}"
+ done
+
+ if use cgi ; then
+ dodir /usr/share/${PN}/gitweb
+ insinto /usr/share/${PN}/gitweb
+ doins "${S}"/gitweb/gitweb.{cgi,css}
+ doins "${S}"/gitweb/git-{favicon,logo}.png
+ docinto /
+ # INSTALL discusses configuration issues, not just installation
+ newdoc "${S}"/gitweb/INSTALL INSTALL.gitweb
+ newdoc "${S}"/gitweb/README README.gitweb
+ fi
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ has_version app-arch/unzip || \
+ rm "${S}"/t/t5000-tar-tree.sh
+ # Stupid CVS won't let some people commit as root
+ if has userpriv "${FEATURES}"; then
+ einfo "Enabling CVS tests as we have FEATURES=userpriv"
+ else
+ ewarn "Skipping CVS tests because CVS does not work as root!"
+ ewarn "You should retest with FEATURES=userpriv!"
+ for i in t9200-git-cvsexportcommit.sh t9600-cvsimport.sh ; do
+ rm "${S}"/t/${i} || die "Failed to remove ${i}"
+ done
+ fi
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ if use emacs ; then
+ elisp-site-regen
+ elog "GNU Emacs has built-in Git support in versions greater 22.1."
+ elog "You can disable the emacs USE flag for dev-util/git"
+ elog "if you are using such a version."
+ fi
+ elog "These additional scripts need some dependencies:"
+ elog "(These are also needed for FEATURES=test)"
+ echo
+ showpkgdeps git-archimport "dev-util/tla"
+ showpkgdeps git-cvsimport ">=dev-util/cvsps-2.1"
+ showpkgdeps git-svnimport "dev-util/subversion(USE=perl)"
+ showpkgdeps git-svn \
+ "dev-util/subversion(USE=perl)" \
+ "dev-perl/libwww-perl" \
+ "dev-perl/TermReadKey"
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-cvsserver "dev-perl/DBI" "dev-perl/DBD-SQLite"
+ showpkgdeps git-instaweb \
+ "|| ( www-servers/lighttpd www-servers/apache(SLOT=2) )"
+ showpkgdeps git-send-email "USE=perl"
+ showpkgdeps git-remote "USE=perl"
+ echo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}