summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-07-14 21:12:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-07-14 21:12:26 +0000
commita64d0abe4ba0e8273dae43f510d20b6170392632 (patch)
tree5174370158ab34782f7f38bec1d207d49c0c76da /dev-util
parentdon't force 2.4.1 of plotutils as suggested in bug 253542 by <orionbelt2 AT g... (diff)
downloadgentoo-2-a64d0abe4ba0e8273dae43f510d20b6170392632.tar.gz
gentoo-2-a64d0abe4ba0e8273dae43f510d20b6170392632.tar.bz2
gentoo-2-a64d0abe4ba0e8273dae43f510d20b6170392632.zip
Bump to 1.4.0, fixes #277742
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/valkyrie/ChangeLog7
-rw-r--r--dev-util/valkyrie/valkyrie-1.4.0.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-util/valkyrie/ChangeLog b/dev-util/valkyrie/ChangeLog
index c8c257f32cde..2c5e366991dd 100644
--- a/dev-util/valkyrie/ChangeLog
+++ b/dev-util/valkyrie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/valkyrie
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valkyrie/ChangeLog,v 1.11 2009/01/05 19:02:24 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valkyrie/ChangeLog,v 1.12 2009/07/14 21:12:26 patrick Exp $
+
+*valkyrie-1.4.0 (14 Jul 2009)
+
+ 14 Jul 2009; Patrick Lauer <patrick@gentoo.org> +valkyrie-1.4.0.ebuild:
+ Bump to 1.4.0, fixes #277742
05 Jan 2009; Maurice van der Pot <griffon26@gentoo.org>
-files/valkyrie-1.2.0-warnings.patch, -valkyrie-1.2.0.ebuild:
diff --git a/dev-util/valkyrie/valkyrie-1.4.0.ebuild b/dev-util/valkyrie/valkyrie-1.4.0.ebuild
new file mode 100644
index 000000000000..a9f5efacecdd
--- /dev/null
+++ b/dev-util/valkyrie/valkyrie-1.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valkyrie/valkyrie-1.4.0.ebuild,v 1.1 2009/07/14 21:12:26 patrick Exp $
+
+EAPI=1
+inherit eutils qt3 autotools
+
+DESCRIPTION="Graphical front-end to the Valgrind suite of tools"
+HOMEPAGE="http://www.open-works.co.uk/projects/valkyrie.html"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt:3"
+RDEPEND="${DEPEND}
+ =dev-util/valgrind-3.4*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.3.0-asneeded.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ use debug || sed -i -e '/#define DEBUG_ON/ s:1:0:' \
+ "${S}/valkyrie/vk_utils.h"
+
+ econf \
+ --disable-dependency-tracking \
+ --with-Qt-dir="${QTDIR}" || die "econf failed"
+
+ # Use the right path for the documentation
+ sed -i -e '/VK_DOC_PATH/ s:/doc/:/share/doc/'${PF}'/html/:g' \
+ "${S}/config.h"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install
+
+ dodoc README README_DEVELOPERS AUTHORS
+}