summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-02-11 10:55:11 +0000
committerMichael Januszewski <spock@gentoo.org>2004-02-11 10:55:11 +0000
commit8580727b74a0f0add60753b5429604ff8b3068da (patch)
treefb365162a70a51422a4936417f4a1ae8cb66a662 /dev-util
parentversion bump. fixes GTK1 default thanks to Piotr Piasny <p1t3r05 os.pl> and k... (diff)
downloadgentoo-2-8580727b74a0f0add60753b5429604ff8b3068da.tar.gz
gentoo-2-8580727b74a0f0add60753b5429604ff8b3068da.tar.bz2
gentoo-2-8580727b74a0f0add60753b5429604ff8b3068da.zip
Sandbox violations fix, closes #40953.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/oprofile/ChangeLog5
-rw-r--r--dev-util/oprofile/oprofile-0.7.1.ebuild16
2 files changed, 18 insertions, 3 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 82bb0680ef59..9598e2097b1c 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.2 2004/02/01 19:57:28 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.3 2004/02/11 10:55:11 spock Exp $
+
+ 11 Feb 2004; Michal Januszewski <spock@gentoo.org> oprofile-0.7.1.ebuild:
+ Fixed sandbox violations when emerged with qt USE flag. Closes #40953.
*oprofile-0.7.1 (01 Feb 2004)
diff --git a/dev-util/oprofile/oprofile-0.7.1.ebuild b/dev-util/oprofile/oprofile-0.7.1.ebuild
index ba517399671b..1029c805b7fe 100644
--- a/dev-util/oprofile/oprofile-0.7.1.ebuild
+++ b/dev-util/oprofile/oprofile-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.7.1.ebuild,v 1.1 2004/02/01 19:57:28 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.7.1.ebuild,v 1.2 2004/02/11 10:55:11 spock Exp $
DESCRIPTION="A transparent low-overhead system-wide profiler"
HOMEPAGE="http://oprofile.sourceforge.net"
@@ -21,7 +21,19 @@ src_compile() {
local myconf=""
- use qt || myconf="${myconf} --with-qt-dir=/void"
+ if [ `use qt` ]
+ then
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+ else
+ myconf="${myconf} --with-qt-dir=/void"
+ fi
myconf="${myconf} --with-x"
# note: compilation has only been tested with a 2.4 kernel