summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-04 22:20:48 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-04 22:20:48 +0000
commit78338b00307f7aacbaa7ad2478b8fb46f56dff8f (patch)
tree76ac57e7ed43b3a5c39c469d65aa1aa52854fa60 /dev-util
parentQA: Fixed typo in freebsd-lib blocker, respect CC (bug 243916) (diff)
downloadgentoo-2-78338b00307f7aacbaa7ad2478b8fb46f56dff8f.tar.gz
gentoo-2-78338b00307f7aacbaa7ad2478b8fb46f56dff8f.tar.bz2
gentoo-2-78338b00307f7aacbaa7ad2478b8fb46f56dff8f.zip
Bump to 1.0.16, fixes #140274
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cvsd/ChangeLog9
-rw-r--r--dev-util/cvsd/cvsd-1.0.16.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-util/cvsd/ChangeLog b/dev-util/cvsd/ChangeLog
index e8055fc2d461..d383c41feea2 100644
--- a/dev-util/cvsd/ChangeLog
+++ b/dev-util/cvsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cvsd
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsd/ChangeLog,v 1.25 2007/03/19 02:20:10 kloeri Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsd/ChangeLog,v 1.26 2009/01/04 22:20:48 patrick Exp $
+
+*cvsd-1.0.16 (04 Jan 2009)
+
+ 04 Jan 2009; Patrick Lauer <patrick@gentoo.org> +cvsd-1.0.16.ebuild:
+ Bump to 1.0.16, fixes #140274
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/dev-util/cvsd/cvsd-1.0.16.ebuild b/dev-util/cvsd/cvsd-1.0.16.ebuild
new file mode 100644
index 000000000000..45885079d9ad
--- /dev/null
+++ b/dev-util/cvsd/cvsd-1.0.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsd/cvsd-1.0.16.ebuild,v 1.1 2009/01/04 22:20:48 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="CVS pserver daemon."
+HOMEPAGE="http://ch.tudelft.nl/~arthur/cvsd/"
+SRC_URI="http://ch.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="tcpd"
+
+DEPEND="virtual/libc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+RDEPEND="${DEPEND}
+ >=dev-lang/perl-5.8.0
+ >=dev-util/cvs-1.11.6"
+
+pkg_setup() {
+ enewgroup cvsd
+ enewuser cvsd -1 -1 /var/lib/cvsd cvsd
+}
+
+src_compile() {
+ econf $(use_with tcpd libwrap) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dosed 's:^Repos:# Repos:g' /etc/cvsd/cvsd.conf
+ keepdir /var/lib/cvsd
+
+ dodoc AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README TODO
+
+ newinitd ${FILESDIR}/cvsd.rc6 ${PN}
+}
+
+pkg_postinst() {
+ elog "To configure cvsd please read /usr/share/doc/${PF}/README.gz"
+}