summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2014-03-30 20:49:25 +0000
committerDirkjan Ochtman <djc@gentoo.org>2014-03-30 20:49:25 +0000
commit64a3143e1ad0121ef60dd2bb7762129cc453047b (patch)
tree5b1154f4dc1a035a7eb758820e64f31da4a9e0c8 /dev-util
parentRemove unused patch. (diff)
downloadgentoo-2-64a3143e1ad0121ef60dd2bb7762129cc453047b.tar.gz
gentoo-2-64a3143e1ad0121ef60dd2bb7762129cc453047b.tar.bz2
gentoo-2-64a3143e1ad0121ef60dd2bb7762129cc453047b.zip
Version bump rebar to 2.2.0.
(Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rebar/ChangeLog9
-rw-r--r--dev-util/rebar/rebar-2.2.0.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-util/rebar/ChangeLog b/dev-util/rebar/ChangeLog
index 28ac047fa748..51f581123059 100644
--- a/dev-util/rebar/ChangeLog
+++ b/dev-util/rebar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/rebar
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rebar/ChangeLog,v 1.3 2013/03/17 15:48:47 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rebar/ChangeLog,v 1.4 2014/03/30 20:49:25 djc Exp $
+
+*rebar-2.2.0 (30 Mar 2014)
+
+ 30 Mar 2014; Dirkjan Ochtman <djc@gentoo.org> +rebar-2.2.0.ebuild:
+ Version bump rebar to 2.2.0.
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/dev-util/rebar/rebar-2.2.0.ebuild b/dev-util/rebar/rebar-2.2.0.ebuild
new file mode 100644
index 000000000000..cc5f33923411
--- /dev/null
+++ b/dev-util/rebar/rebar-2.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rebar/rebar-2.2.0.ebuild,v 1.1 2014/03/30 20:49:25 djc Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="http://github.com/rebar/rebar"
+SRC_URI="http://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}