summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-07 18:13:06 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-07 18:13:06 +0000
commit2cdf142dc580f7ffe66266ad5cc9a84bf3ae8073 (patch)
tree8beb2271a0cab9d691a48f5c4a424db75b8c115f /dev-util
parentAdd ~ia64/~sparc wrt #351835 (diff)
downloadgentoo-2-2cdf142dc580f7ffe66266ad5cc9a84bf3ae8073.tar.gz
gentoo-2-2cdf142dc580f7ffe66266ad5cc9a84bf3ae8073.tar.bz2
gentoo-2-2cdf142dc580f7ffe66266ad5cc9a84bf3ae8073.zip
Add upstream patch to restore functionality, bug 374521
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/kscope/ChangeLog10
-rw-r--r--dev-util/kscope/files/kscope-1.9.4-actions.patch90
-rw-r--r--dev-util/kscope/kscope-1.9.4-r1.ebuild38
3 files changed, 136 insertions, 2 deletions
diff --git a/dev-util/kscope/ChangeLog b/dev-util/kscope/ChangeLog
index cb81d178a33d..0860e6b06a50 100644
--- a/dev-util/kscope/ChangeLog
+++ b/dev-util/kscope/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/kscope
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kscope/ChangeLog,v 1.50 2010/02/01 17:48:01 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kscope/ChangeLog,v 1.51 2011/08/07 18:13:06 dilfridge Exp $
+
+*kscope-1.9.4-r1 (07 Aug 2011)
+
+ 07 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kscope-1.9.4-r1.ebuild, +files/kscope-1.9.4-actions.patch:
+ Add upstream patch to restore functionality, bug 374521
01 Feb 2010; Markos Chandras <hwoarang@gentoo.org> kscope-1.9.4.ebuild:
Various clean up and installation fixes based on new qscintilla
diff --git a/dev-util/kscope/files/kscope-1.9.4-actions.patch b/dev-util/kscope/files/kscope-1.9.4-actions.patch
new file mode 100644
index 000000000000..d333efb0ab09
--- /dev/null
+++ b/dev-util/kscope/files/kscope-1.9.4-actions.patch
@@ -0,0 +1,90 @@
+--- trunk/app/actions.cpp 2009/08/26 13:17:03 203
++++ trunk/app/actions.cpp 2009/09/07 19:58:30 204
+@@ -264,69 +264,58 @@
+ QActionGroup* queryGroup = new QActionGroup(this);
+ connect(queryGroup, SIGNAL(triggered(QAction*)), this,
+ SLOT(query(QAction*)));
++ connect(ProjectManager::signalProxy(), SIGNAL(hasProject(bool)),
++ queryGroup, SLOT(setEnabled(bool)));
++ queryGroup->setEnabled(false);
+
+ // Query references.
+- action = new QAction(tr("&References"), this);
++ action = new QAction(tr("&References"), queryGroup);
+ action->setShortcut(tr("Ctrl+0"));
+ action->setStatusTip(tr("Find all symbol references"));
+ action->setData(Core::Query::References);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Query definition.
+- action = new QAction(tr("&Definition"), this);
++ action = new QAction(tr("&Definition"), queryGroup);
+ action->setShortcut(tr("Ctrl+1"));
+ action->setStatusTip(tr("Find symbol definition"));
+ action->setData(Core::Query::Definition);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Query called functions.
+- action = new QAction(tr("&Called Functions"), this);
++ action = new QAction(tr("&Called Functions"), queryGroup);
+ action->setShortcut(tr("Ctrl+2"));
+ action->setStatusTip(tr("Show functions called from function"));
+ action->setData(Core::Query::CalledFunctions);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Query calling functions.
+- action = new QAction(tr("C&alling Functions"), this);
++ action = new QAction(tr("C&alling Functions"), queryGroup);
+ action->setShortcut(tr("Ctrl+3"));
+ action->setStatusTip(tr("Find functions calling function"));
+ action->setData(Core::Query::CallingFunctions);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Query text.
+- action = new QAction(tr("&Text"), this);
++ action = new QAction(tr("&Text"), queryGroup);
+ action->setShortcut(tr("Ctrl+4"));
+ action->setStatusTip(tr("Find text in files"));
+ action->setData(Core::Query::Text);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Find file.
+- action = new QAction(tr("&File"), this);
++ action = new QAction(tr("&File"), queryGroup);
+ action->setShortcut(tr("Ctrl+7"));
+ action->setStatusTip(tr("Find a file"));
+ action->setData(Core::Query::FindFile);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Find including files.
+- action = new QAction(tr("&Including Files"), this);
++ action = new QAction(tr("&Including Files"), queryGroup);
+ action->setShortcut(tr("Ctrl+8"));
+ action->setStatusTip(tr("Find files #including a given file"));
+ action->setData(Core::Query::IncludingFiles);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Show local tags.
+ action = new QAction(tr("Local &Tags"), this);
+@@ -348,6 +337,7 @@
+ action->setStatusTip(tr("Create a call tree"));
+ connect(action, SIGNAL(triggered()), mainWnd(), SLOT(promptCallTree()));
+ menu->addAction(action);
++ projectGroup->addAction(action);
+
+ // Settings menu.
+ menu = mainWnd()->menuBar()->addMenu(tr("&Settings"));
diff --git a/dev-util/kscope/kscope-1.9.4-r1.ebuild b/dev-util/kscope/kscope-1.9.4-r1.ebuild
new file mode 100644
index 000000000000..dee87f5ad03c
--- /dev/null
+++ b/dev-util/kscope/kscope-1.9.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kscope/kscope-1.9.4-r1.ebuild,v 1.1 2011/08/07 18:13:06 dilfridge Exp $
+
+EAPI=4
+
+inherit eutils multilib qt4-r2
+
+DESCRIPTION="Source Editing Environment for KDE"
+HOMEPAGE="http://kscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kscope/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qscintilla"
+DEPEND="${RDEPEND}"
+
+DOCS="ChangeLog"
+
+src_prepare() {
+ sed -i -e "s:/usr/local:/usr:" config || die
+ sed -i \
+ -e "s:\$\${QSCI_ROOT_PATH}/include/Qsci:& /usr/include/qt4/Qsci:g" \
+ -e "s:\$\${QSCI_ROOT_PATH}/lib:& -L/usr/lib/qt4:g" \
+ -e "s:/lib:/$(get_libdir):g" \
+ app/app.pro core/core.pro cscope/cscope.pro editor/editor.pro \
+ || die
+
+ # fix build failure with parallel make
+ echo "CONFIG += ordered" >> kscope.pro
+
+ epatch "${FILESDIR}/${P}-actions.patch"
+}