summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-20 18:48:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-20 18:48:48 +0000
commit1c36fcf011c0f823b69be44a8db56a4c899add37 (patch)
treedad60fa6b99a30f67f34a204ff502fc1ab1c58cb /dev-util
parentamd64 stable wrt #306099 (diff)
downloadgentoo-2-1c36fcf011c0f823b69be44a8db56a4c899add37.tar.gz
gentoo-2-1c36fcf011c0f823b69be44a8db56a4c899add37.tar.bz2
gentoo-2-1c36fcf011c0f823b69be44a8db56a4c899add37.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 15411-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot/ChangeLog6
-rw-r--r--dev-util/buildbot/buildbot-0.7.12.ebuild32
2 files changed, 19 insertions, 19 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index 4695eedaad98..e7eb987a513e 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.54 2010/02/19 15:33:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.55 2010/02/20 18:48:48 arfrever Exp $
+
+ 20 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ buildbot-0.7.12.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*buildbot-0.7.12 (19 Feb 2010)
diff --git a/dev-util/buildbot/buildbot-0.7.12.ebuild b/dev-util/buildbot/buildbot-0.7.12.ebuild
index 78cba26508eb..f9876893f29c 100644
--- a/dev-util/buildbot/buildbot-0.7.12.ebuild
+++ b/dev-util/buildbot/buildbot-0.7.12.ebuild
@@ -1,18 +1,22 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.12.ebuild,v 1.1 2010/02/19 15:33:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.12.ebuild,v 1.2 2010/02/20 18:48:48 arfrever Exp $
-EAPI=1
-NEED_PYTHON="2.4"
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="trial"
+DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
+
+inherit distutils eutils
MY_PV="${PV/_p/p}"
MY_P="${PN}-${MY_PV}"
-inherit eutils distutils
-
DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
HOMEPAGE="http://buildbot.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -30,6 +34,7 @@ DEPEND="${CDEPEND}
dev-python/twisted-web
dev-python/twisted-words )
doc? ( =dev-python/epydoc-2* )"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
@@ -37,26 +42,17 @@ pkg_setup() {
enewuser buildbot
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ distutils_src_prepare
epatch "${FILESDIR}/${PN}-0.7.5-root-skip-tests.patch"
}
src_compile() {
distutils_src_compile
- if use doc; then
- PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
- die "epyrun failed"
- fi
-}
-src_test() {
- local trialopts
- if ! has_version ">=dev-python/twisted-2.2"; then
- trialopts=-R
+ if use doc; then
+ PYTHONPATH="." "$(PYTHON -f)" docs/epyrun -o docs/reference || die "epyrun failed"
fi
- PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
}
src_install() {